summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-09-04 12:34:55 -0500
committerCarlos Aznarán Laos2022-09-04 12:34:55 -0500
commitd662902c62819cab3033f6493ba07016d989f0f6 (patch)
tree30d1af5fda9c871ada902ad43d7087fd7675629a
parent4ce6c0a1d8ccaa3512b5aa261d76a8a8bbf18db1 (diff)
downloadaur-d662902c62819cab3033f6493ba07016d989f0f6.tar.gz
Bump version to 5.2.3
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD49
3 files changed, 38 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ee2dd7345a4..e4ea3216c492 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = libxc
pkgdesc = A library of exchange-correlation functionals for density-functional theory
- pkgver = 5.1.5
- pkgrel = 2
+ pkgver = 5.2.3
+ pkgrel = 1
url = https://www.tddft.org/programs/libxc
arch = i686
arch = x86_64
arch = aarch64
license = MPL2
- makedepends = gcc
makedepends = gcc-fortran
+ makedepends = cmake
+ depends = python-numpy
options = staticlibs
- source = http://www.tddft.org/programs/libxc/down.php?file=5.1.5/libxc-5.1.5.tar.gz
- sha256sums = 02e4615a22dc3ec87a23efbd3d9be5bfad2445337140bad1720699571c45c3f9
+ source = https://www.tddft.org/programs/libxc/down.php?file=5.2.3/libxc-5.2.3.tar.gz
+ sha512sums = e7a5100af2a4a1d0aee773919cca31bfffdc2a8c0a04d9df9247df5ec78a9ef13d1da9585cc6e3f3f96f6a974cafc762493d66d2fd7dea312b9e0f4dee3c934f
pkgname = libxc
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 9b5455d753d7..753c31ba3b30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,42 @@
-# Maintainer: James Spencer <james.s.spencer@gmail.com>
-
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Maintainer: Jingbei Li <i@jingbei.li>
+# Contributor: James Spencer <james.s.spencer@gmail.com>
+# Contributor: Anton Kudelin <kudelin at protonmail dot com>
pkgname=libxc
-pkgver=5.1.5
-pkgrel=2
+pkgver=5.2.3
+pkgrel=1
pkgdesc="A library of exchange-correlation functionals for density-functional theory"
arch=('i686' 'x86_64' 'aarch64')
-url="https://www.tddft.org/programs/libxc"
+url="https://www.tddft.org/programs/${pkgname}"
license=('MPL2')
-makedepends=('gcc' 'gcc-fortran')
-source=(http://www.tddft.org/programs/$pkgname/down.php?file=$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('02e4615a22dc3ec87a23efbd3d9be5bfad2445337140bad1720699571c45c3f9')
+depends=(python-numpy)
+makedepends=(gcc-fortran cmake)
+source=(${url}/down.php?file=${pkgver}/${pkgname}-${pkgver}.tar.gz)
+sha512sums=('e7a5100af2a4a1d0aee773919cca31bfffdc2a8c0a04d9df9247df5ec78a9ef13d1da9585cc6e3f3f96f6a974cafc762493d66d2fd7dea312b9e0f4dee3c934f')
options=(staticlibs)
build() {
- mkdir "$srcdir/build"
- cd "$srcdir/build"
- cmake $srcdir/$pkgname-$pkgver \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_SHARED_LIBS=ON \
- -DENABLE_FORTRAN=ON \
- -DENABLE_FORTRAN03=ON
- make
+ cmake \
+ -S ${pkgname}-${pkgver} \
+ -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_TESTING=ON \
+ -DENABLE_FORTRAN=ON \
+ -DENABLE_GENERIC=ON \
+ -DENABLE_PYTHON=ON \
+ -DENABLE_XHOST=ON \
+ -DCMAKE_POSITION_INDEPENDENT_CODE=TRUE \
+ -Wno-dev
+ cmake --build build --target all
+}
+
+check() {
+ ctest --output-on-failure --test-dir build
}
package() {
- cd "$srcdir/build"
- make DESTDIR="$pkgdir/" install
+ DESTDIR="${pkgdir}" cmake --build build --target install
+ install -Dm 644 ${pkgname}-${pkgver}/COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}