summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Mezin2015-08-11 20:09:57 +0600
committerAlexander Mezin2015-08-11 20:09:57 +0600
commit40472037d178ef5f6fe11e41466077cdc41d0e32 (patch)
treea53ab5f85000469e7460f33ac289b9c39cd726bb
downloadaur-40472037d178ef5f6fe11e41466077cdc41d0e32.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD51
-rw-r--r--libxcb-1.1-no-pthread-stubs.patch11
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a9956036b65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = libxcb-git
+ pkgdesc = X11 client-side library - git version
+ pkgver = 1.11.r58.gb15c96f
+ pkgrel = 1
+ url = http://xcb.freedesktop.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = libxslt
+ makedepends = python
+ depends = xcb-proto-git
+ depends = libxdmcp
+ depends = libxau
+ provides = libxcb=1.11.r58.gb15c96f
+ conflicts = libxcb
+ source = git+http://anongit.freedesktop.org/git/xcb/libxcb.git
+ source = libxcb-1.1-no-pthread-stubs.patch
+ sha256sums = SKIP
+ sha256sums = 3923bcb1930b851012968435909597d8d5251c72153511cb2982636c97100cc3
+
+pkgname = libxcb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a917c794ce4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: Doug Newgard <scimmia22 at outlook dot com>
+# Contributor: NeoRaider <neoraider@universe-factory.net>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=libxcb-git
+pkgver=1.11.r58.gb15c96f
+pkgrel=1
+pkgdesc="X11 client-side library - git version"
+arch=('i686' 'x86_64')
+url="http://xcb.freedesktop.org/"
+depends=('xcb-proto-git' 'libxdmcp' 'libxau')
+makedepends=('git' 'libxslt' 'python')
+conflicts=('libxcb')
+provides=("libxcb=$pkgver")
+license=('custom')
+source=("git+http://anongit.freedesktop.org/git/xcb/libxcb.git"
+ 'libxcb-1.1-no-pthread-stubs.patch')
+sha256sums=('SKIP'
+ '3923bcb1930b851012968435909597d8d5251c72153511cb2982636c97100cc3')
+
+pkgver() {
+ cd $srcdir/${pkgname%-*}
+ git describe --tags | sed 's/-/.r/;s/-/./g'
+}
+
+prepare() {
+ cd $srcdir/${pkgname%-*}
+
+ patch -Np1 < ../libxcb-1.1-no-pthread-stubs.patch
+}
+
+build() {
+ cd $srcdir/${pkgname%-*}
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --enable-xinput \
+ --enable-xkb \
+ --disable-static
+
+ make
+}
+
+package() {
+ cd $srcdir/${pkgname%-*}
+
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+# vim:set ts=2 sw=2 bs=2:
diff --git a/libxcb-1.1-no-pthread-stubs.patch b/libxcb-1.1-no-pthread-stubs.patch
new file mode 100644
index 000000000000..84c7f8e2fb67
--- /dev/null
+++ b/libxcb-1.1-no-pthread-stubs.patch
@@ -0,0 +1,11 @@
+--- libxcb-1.8.1/configure.ac 2012-03-09 15:38:38.000000000 +0100
++++ libxcb-1.8.1/configure.ac.new 2012-03-09 16:50:40.107109896 +0100
+@@ -43,7 +43,7 @@
+
+ # Checks for pkg-config packages
+ PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.11)
+-NEEDED="pthread-stubs xau >= 0.99.2"
++NEEDED="xau >= 0.99.2"
+ PKG_CHECK_MODULES(NEEDED, $NEEDED)
+
+ have_xdmcp="no"