summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-10-02 10:11:41 +0200
committerPhilipp A2020-10-02 10:11:41 +0200
commitb69e1f1f3eb57e7e7f462e7b57da602150875f21 (patch)
treeb21fdb1f83b3b03228d1847a1756e4d0ab795650
parentdcc08dba9e779bfd44eda49ba6237fc5cfec5d31 (diff)
downloadaur-b69e1f1f3eb57e7e7f462e7b57da602150875f21.tar.gz
correctly infer version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b524b5e77493..7cd028a4ec63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = libxcb-git
pkgdesc = X11 client-side library - git version
- pkgver = 1.12.r7.gf830eb9
+ pkgver = 1.14.r1.g704e0a9
pkgrel = 1
url = http://xcb.freedesktop.org
arch = i686
arch = x86_64
license = custom
makedepends = git
+ makedepends = libxslt
makedepends = python
makedepends = xorg-util-macros
- makedepends = libxslt
- makedepends = libpthread-stubs
+ makedepends = xorgproto
depends = xcb-proto-git
depends = libxdmcp
depends = libxau
- provides = libxcb=1.12.r7.gf830eb9
+ provides = libxcb=1.14.r1.g704e0a9
conflicts = libxcb
source = git+http://anongit.freedesktop.org/git/xcb/libxcb.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5b90ab7dde52..952bcbc3a98c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,22 @@
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=libxcb-git
-pkgver=1.12.r7.gf830eb9
+pkgver=1.14.r1.g704e0a9
pkgrel=1
pkgdesc='X11 client-side library - git version'
arch=(i686 x86_64)
url='http://xcb.freedesktop.org'
depends=(xcb-proto-git libxdmcp libxau)
-makedepends=(git python xorg-util-macros libxslt libpthread-stubs)
+makedepends=(git libxslt python xorg-util-macros xorgproto)
conflicts=(libxcb)
provides=("libxcb=$pkgver")
license=(custom)
source=('git+http://anongit.freedesktop.org/git/xcb/libxcb.git')
-sha256sums=(SKIP)
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-*}"
- git describe --tags | sed 's/-/.r/;s/-/./g'
+ git describe --tags | sed 's/libxcb-//;s/-/.r/;s/-/./g'
}
build() {
@@ -29,6 +29,7 @@ build() {
--prefix=/usr \
--enable-xinput \
--enable-xkb \
+ --with-doxygen=no \
--disable-static
make