summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 18:31:43 +0200
committersl1pkn072015-06-08 18:31:43 +0200
commitd93e883a50aceb53fdfe127aa1d111512cc93a00 (patch)
tree72d53c68f774614ea5cda6a79a96caa4e2c4cd59
downloadaur-d93e883a50aceb53fdfe127aa1d111512cc93a00.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe2e1f3f91c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libxcm-git
+ pkgdesc = A library containing the a reference implementation of the net-color specs. (GIT version)
+ pkgver = 0.5.3.17.gad12c37
+ pkgrel = 1
+ url = http://www.oyranos.org/libxcm/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = libxfixes
+ depends = libxmu
+ provides = libxcm
+ conflicts = libxcm
+ source = git+https://github.com/oyranos-cms/libxcm.git
+ md5sums = SKIP
+
+pkgname = libxcm-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d8a3ff9d909
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+
+pkgname=libxcm-git
+pkgver=0.5.3.17.gad12c37
+pkgrel=1
+pkgdesc="A library containing the a reference implementation of the net-color specs. (GIT version)"
+arch=('i686' 'x86_64')
+url="http://www.oyranos.org/libxcm/"
+license=('BSD')
+depends=('libxfixes' 'libxmu')
+makedepends=('git')
+conflicts=('libxcm')
+provides=('libxcm')
+source=("git+https://github.com/oyranos-cms/libxcm.git")
+md5sums=('SKIP')
+_gitname="libxcm"
+
+pkgver() {
+ cd libxcm
+ echo "$(git describe --long --tags | sed 's|libXcm-||g' | tr - .)"
+}
+
+build() {
+ cd libxcm
+ LDFLAGS+=" -lm" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ make -C libxcm DESTDIR="${pkgdir}" install
+ install -Dm644 libxcm/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+