summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-08-28 14:46:13 +0800
committerChocobo12020-08-28 14:46:13 +0800
commit31f073e9f3442601f4a8840b6906570fb66f25a4 (patch)
treeeef83c0f291a82c180f17d049c3526f5c1890f94
downloadaur-31f073e9f3442601f4a8840b6906570fb66f25a4.tar.gz
newpkg: libxcrypt-git 4.4.17.r1.gb475497-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD47
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8b848143aa3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libxcrypt-git
+ pkgdesc = Library for one-way hashing of passwords
+ pkgver = 4.4.17.r1.gb475497
+ pkgrel = 1
+ url = https://github.com/besser82/libxcrypt/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ provides = libxcrypt
+ provides = libcrypt.so
+ conflicts = libxcrypt
+ options = staticlibs
+ source = git+https://github.com/besser82/libxcrypt.git
+ sha256sums = SKIP
+
+pkgname = libxcrypt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97ea2691fac5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libxcrypt-git
+pkgver=4.4.17.r1.gb475497
+pkgrel=1
+pkgdesc="Library for one-way hashing of passwords"
+arch=('i686' 'x86_64')
+url="https://github.com/besser82/libxcrypt/"
+license=('LGPL')
+depends=('glibc')
+makedepends=('git')
+provides=('libxcrypt' 'libcrypt.so')
+conflicts=('libxcrypt')
+options=('staticlibs')
+source=("git+https://github.com/besser82/libxcrypt.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libxcrypt"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libxcrypt"
+
+ ./autogen.sh
+ ./configure \
+ --prefix="/usr" \
+ --disable-failure-tokens \
+ --enable-hashes=strong,glibc \
+ --enable-obsolete-api=no
+ make
+}
+
+check() {
+ cd "libxcrypt"
+
+ make check
+}
+
+package() {
+ cd "libxcrypt"
+
+ make DESTDIR="$pkgdir" install
+}