summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2021-09-19 08:57:42 +0300
committerYurii Kolesnykov2021-09-19 08:57:42 +0300
commit051962704f3691b55613da12a6ca172bfe1ecc26 (patch)
treeb89aae3242d3c9c8858a0ad7437eaa00ffc0c19f
parent3993673d2d796735b22f48740c31a08287cb1ca2 (diff)
downloadaur-051962704f3691b55613da12a6ca172bfe1ecc26.tar.gz
sync extra/libxcvt
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3d9e7c5c597..95644859921f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = libxcvt-git
- pkgdesc = libxcvt is a library providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator.
- pkgver = 0.1.0+2+gdb5141a
+ pkgdesc = library providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator
+ pkgver = 0.1.0+3+g69fb7bf
pkgrel = 1
url = https://gitlab.freedesktop.org/xorg/lib/libxcvt
- arch = any
+ arch = x86_64
license = custom
makedepends = git
makedepends = meson
diff --git a/PKGBUILD b/PKGBUILD
index b79776f30f4c..502fd5e81cb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
pkgname=libxcvt-git
_pkgname=libxcvt
-pkgver=0.1.0+2+gdb5141a
+pkgver=0.1.0+3+g69fb7bf
pkgrel=1
-pkgdesc="libxcvt is a library providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator."
-arch=(any)
-url="https://gitlab.freedesktop.org/xorg/lib/libxcvt"
+pkgdesc="library providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator"
+arch=(x86_64)
+url='https://gitlab.freedesktop.org/xorg/lib/libxcvt'
license=('custom')
depends=('glibc')
provides=("${_pkgname}")
@@ -14,12 +14,11 @@ source=("git+${url}.git")
b2sums=('SKIP')
pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/libxcvt-//g ; s/-/+/g'
+ git -C "${_pkgname}" describe --tags | sed 's/libxcvt-//g ; s/-/+/g'
}
build() {
- arch-meson $_pkgname build
+ arch-meson "${_pkgname}" build
meson compile -C build
}
@@ -28,6 +27,6 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
- install -m644 -Dt "${pkgdir}/usr/share/licenses/${_pkgname}" "${_pkgname}/COPYING"
+ DESTDIR="${pkgdir}" meson install -C build
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${_pkgname}/COPYING"
}