summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2021-08-06 21:52:36 +0200
committerKevin Majewski2021-08-06 21:52:36 +0200
commitfb8e2d7d0695675967cf1ae57a0318816e652ebb (patch)
tree76729ecd5931c46695d818ecbcf396203d79be3d
downloadaur-fb8e2d7d0695675967cf1ae57a0318816e652ebb.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81a35cb4ed7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libxcvt-git
+ pkgdesc = libxcvt is a library providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator.
+ pkgver = 0.1.0+2+gdb5141a
+ pkgrel = 1
+ url = https://github.com/Unrud/video-downloader
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = meson
+ depends = glibc
+ source = git+https://gitlab.freedesktop.org/xorg/lib/libxcvt.git
+ b2sums = SKIP
+
+pkgname = libxcvt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad32cc57a333
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=libxcvt-git
+_pkgname=libxcvt
+pkgver=0.1.0+2+gdb5141a
+pkgrel=1
+pkgdesc="libxcvt is a library providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator."
+arch=(any)
+url="https://github.com/Unrud/video-downloader"
+license=('custom')
+depends=('glibc')
+makedepends=('git' 'meson')
+source=("git+https://gitlab.freedesktop.org/xorg/lib/libxcvt.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/libxcvt-//g ; s/-/+/g'
+}
+
+build() {
+ arch-meson $_pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${_pkgname}" "${_pkgname}/COPYING"
+}