summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Temple2020-06-06 06:27:41 -0700
committerWill Temple2020-06-06 06:27:41 -0700
commite445c03efc77329ae1ca391029ee32a979e78f06 (patch)
tree4f9ee9d191308ec32fdbfb5d91e0a32035144c98
parentda0cf7690381cec707f4b038f513661eeeb03bb0 (diff)
downloadaur-e445c03efc77329ae1ca391029ee32a979e78f06.tar.gz
Use curl instead of git-fetch
-rw-r--r--PKGBUILD14
1 files changed, 1 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c9eef6de320..bcf1c964de3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,20 +27,8 @@ pkgver() {
prepare() {
set -eo pipefail
- # Create git repository to hold gitlab upstream code and create diff
- if [ -d "libxft_upstream" ]; then
- rm -rf "libxft_upstream";
- fi;
-
- mkdir libxft_upstream
- pushd libxft_upstream
- git init
- git remote add upstream ${LIBXFT_UPSTREAM_URL}
- git fetch --depth=2 upstream ${COMMIT_ID}
- popd
-
pushd libXft-${_pkgbasever}
- git --git-dir ../libxft_upstream/.git diff -u ${COMMIT_ID}~ ${COMMIT_ID} | patch -p1
+ curl -S https://gitlab.freedesktop.org/xorg/lib/libxft/-/commit/${COMMIT_ID}.patch | patch -p1
popd
set +eo pipefail