summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-05-16 20:41:23 +0800
committerChocobo12019-05-16 20:41:23 +0800
commit435d9bad664079a6233d1044cea57eefb3c6aace (patch)
tree5bc5c23de04876150effe34b9f3cb577e3e5fddb
downloadaur-435d9bad664079a6233d1044cea57eefb3c6aace.tar.gz
newpkg: libxi-git 1.7.9.r8.g3e38d82-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d888d5ba9ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libxi-git
+ pkgdesc = X11 Input extension library
+ pkgver = 1.7.9.r8.g3e38d82
+ pkgrel = 1
+ url = https://www.x.org/wiki/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = libxfixes
+ makedepends = xorg-util-macros
+ depends = glibc
+ depends = inputproto
+ depends = libxext
+ provides = libxi
+ conflicts = libxi
+ options = staticlibs
+ source = git+https://gitlab.freedesktop.org/xorg/lib/libxi.git
+ sha256sums = SKIP
+
+pkgname = libxi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..378e27fe0513
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libxi-git
+pkgver=1.7.9.r8.g3e38d82
+pkgrel=1
+pkgdesc="X11 Input extension library"
+arch=('i686' 'x86_64')
+url="https://www.x.org/wiki/"
+license=('custom')
+depends=('glibc' 'inputproto' 'libxext')
+makedepends=('git' 'libxfixes' 'xorg-util-macros')
+provides=('libxi')
+conflicts=('libxi')
+options=('staticlibs')
+source=("git+https://gitlab.freedesktop.org/xorg/lib/libxi.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libxi"
+
+ git describe --long --tags | sed 's/^libXi-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libxi"
+
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libxi"
+
+ make check
+}
+
+package() {
+ cd "libxi"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/libxi"
+}