summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Teichroeb2015-06-08 16:37:02 -0700
committerJoel Teichroeb2015-06-08 16:37:02 -0700
commit6168ede722d66f91e70f9400d187fa50ba4ff5d2 (patch)
tree39f372fe0b983d09a1720e166a482cd2c0a04911
downloadaur-6168ede722d66f91e70f9400d187fa50ba4ff5d2.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..649641cee227
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = libxkbcommon-git
+ pkgdesc = A library to handle keyboard descriptions.
+ pkgver = 0.5.0.r12.g8e1fed6
+ pkgrel = 1
+ url = http://xkbcommon.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = xorg-util-macros
+ makedepends = libxcb
+ makedepends = doxygen
+ depends = glibc
+ depends = xkeyboard-config
+ provides = libxkbcommon
+ provides = libxkbcommon-x11
+ replaces = libxkbcommon
+ replaces = libxkbcommon-x11
+ source = git://github.com/xkbcommon/libxkbcommon.git
+ sha1sums = SKIP
+
+pkgname = libxkbcommon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06f0361cbcc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Joel Teichroeb <joel@teichroeb.net>
+
+pkgname=libxkbcommon-git
+pkgver=0.5.0.r12.g8e1fed6
+pkgrel=1
+pkgdesc="A library to handle keyboard descriptions."
+url="http://xkbcommon.org/"
+arch=(i686 x86_64)
+license=('custom')
+depends=('glibc' 'xkeyboard-config')
+makedepends=('git' 'xorg-util-macros' 'libxcb' 'doxygen')
+provides=('libxkbcommon' 'libxkbcommon-x11')
+replaces=('libxkbcommon' 'libxkbcommon-x11')
+source=(git://github.com/xkbcommon/libxkbcommon.git)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd libxkbcommon
+ git describe --long | sed -r 's/^xkbcommon.//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd libxkbcommon
+
+ ./autogen.sh --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd libxkbcommon
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+
+ make DESTDIR=${pkgdir} install
+}