summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChromaryu2016-10-04 01:34:05 +0900
committerChromaryu2016-10-04 01:34:05 +0900
commit5468d5cdd79ed0a9d976cd878b3d975a5033a047 (patch)
treebe60c7ed2aa18ec414c22e4df0139c22d77af2b8
parent74205847e042fcd4f4a7436cdf7af96724fae8b1 (diff)
downloadaur-5468d5cdd79ed0a9d976cd878b3d975a5033a047.tar.gz
Update PKGBUILD
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a433a007a14b..eab77ba11a73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
# Maintainer: Chromaryu <knight.ryu12@gmail.com>
pkgname=libxmp-git
-pkgver=4.4.0
+pkgver=libxmp.4.4.0.r59.g6d1fa98
pkgrel=1
pkgdesc="Library that supports over 90 module formats (Amiga, Atari, ..)"
arch=('i686' 'x86_64')
url="http://xmp.sourceforge.net/"
license=('GPL')
-depends=('glibc' 'git')
+depends=('glibc')
optdepends=('pulseaudio')
+makedepends=('git')
conflicts=('libxmp')
provides=('libxmp')
source=("$pkgname"::"git+https://github.com/cmatsuoka/libxmp.git")
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "$srcdir/$pkgname"
autoconf