summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChromaryu2016-09-18 00:40:57 +0900
committerChromaryu2016-09-18 00:40:57 +0900
commit74205847e042fcd4f4a7436cdf7af96724fae8b1 (patch)
tree87839cb2a3e378694a8ef86968b14f6bf031b9fa
downloadaur-74205847e042fcd4f4a7436cdf7af96724fae8b1.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..097a0bba80fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Sep 17 15:39:30 UTC 2016
+pkgbase = libxmp-git
+ pkgdesc = Library that supports over 90 module formats (Amiga, Atari, ..)
+ pkgver = 4.4.0
+ pkgrel = 1
+ url = http://xmp.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ depends = git
+ optdepends = pulseaudio
+ provides = libxmp
+ conflicts = libxmp
+ source = libxmp-git::git+https://github.com/cmatsuoka/libxmp.git
+ md5sums = SKIP
+
+pkgname = libxmp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a433a007a14b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Chromaryu <knight.ryu12@gmail.com>
+pkgname=libxmp-git
+pkgver=4.4.0
+pkgrel=1
+pkgdesc="Library that supports over 90 module formats (Amiga, Atari, ..)"
+arch=('i686' 'x86_64')
+url="http://xmp.sourceforge.net/"
+license=('GPL')
+depends=('glibc' 'git')
+optdepends=('pulseaudio')
+conflicts=('libxmp')
+provides=('libxmp')
+source=("$pkgname"::"git+https://github.com/cmatsuoka/libxmp.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+ autoconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+}