summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-04-30 03:07:15 -0400
committerJames An2015-04-30 03:07:15 -0400
commit284ca69fba2b70fb96afd0aa55e2c4692f740a99 (patch)
tree4b3356e6d48dfe4a6ea34b8074f485fc830e93bd
downloadaur-284ca69fba2b70fb96afd0aa55e2c4692f740a99.tar.gz
Created new AUR package, libxrandr-git.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50a90342b133
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libxrandr-git
+ pkgdesc = X11 RandR extension library. Git version.
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://xorg.freedesktop.org
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = xorg-util-macros
+ makedepends = git
+ depends = libxext
+ depends = libxrender
+ depends = randrproto>=1.5.0
+ provides = libxrandr=1.5.0
+ conflicts = libxrandr
+ source = libxrandr::git+http://anongit.freedesktop.org/git/xorg/lib/libXrandr.git
+ md5sums = SKIP
+
+pkgname = libxrandr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dae8d7b7509a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: James An <james@jamesan.ca>o
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
+
+_pkgname=libxrandr
+pkgname=libxrandr-git
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='X11 RandR extension library. Git version.'
+arch=('i686' 'x86_64')
+license=('custom')
+url='http://xorg.freedesktop.org'
+depends=('libxext' 'libxrender' 'randrproto>=1.5.0')
+makedepends=('xorg-util-macros' 'git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("$_pkgname"::'git+http://anongit.freedesktop.org/git/xorg/lib/libXrandr.git')
+md5sums=('SKIP')
+
+# Version 1.5+ have not been tagged yet, so the pkgver() would a previous minor release number.
+#~ pkgver() {
+ #~ cd "$_pkgname"
+ #~ (
+ #~ set -o pipefail
+ #~ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ #~ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #~ )
+#~ }
+build() {
+ cd "$_pkgname"
+
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/COPYING"
+}