summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:17:35 -0400
committerKyle Keen2015-06-13 00:17:35 -0400
commitea300e2199b32a0a99b87ceb5f732fe587b011dc (patch)
tree5629f7779b3d4137418c310381927a749ee92dec
downloadaur-ea300e2199b32a0a99b87ceb5f732fe587b011dc.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
3 files changed, 60 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..7361d633679c
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = libxs
+ pkgdesc = Fast messaging system built on sockets. Fork of ZeroMQ, Aka Crossroads IO.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/crossroads-io/libxs
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = gcc-libs
+ depends = util-linux
+ provides = zeromq
+ conflicts = zeromq
+ source = http://ftp.de.debian.org/debian/pool/main/libx/libxs/libxs_1.2.0.orig.tar.gz
+
+pkgname = libxs
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fbf498cf587
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libxs
+ pkgdesc = Fast messaging system built on sockets. Fork of ZeroMQ, Aka Crossroads IO.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/crossroads-io/libxs
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = gcc-libs
+ depends = util-linux
+ provides = zeromq
+ conflicts = zeromq
+ source = http://ftp.de.debian.org/debian/pool/main/libx/libxs/libxs_1.2.0.orig.tar.gz
+ md5sums = aac1264bb0d03704bd2126419b981fd5
+
+pkgname = libxs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84d9d6fd0e4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+pkgname=libxs
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Fast messaging system built on sockets. Fork of ZeroMQ, Aka Crossroads IO."
+arch=('i686' 'x86_64')
+#url="http://www.crossroads.io/"
+url="https://github.com/crossroads-io/libxs"
+license=('LGPL')
+depends=('gcc-libs' 'util-linux')
+provides=('zeromq')
+conflicts=('zeromq')
+#source=(http://download.crossroads.io/$pkgname-$pkgver.tar.gz)
+source=(http://ftp.de.debian.org/debian/pool/main/libx/libxs/libxs_1.2.0.orig.tar.gz)
+md5sums=('aac1264bb0d03704bd2126419b981fd5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure prefix=/usr --enable-libzmq
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+