summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli2019-07-06 03:58:47 +0200
committerAlexander Couzens2019-09-10 05:11:57 +0200
commitc05ef71169f76e5e6f604671aa959acbe9d8005f (patch)
tree6c6d6dd64621ba343972d1eeda37bf4815ffd904
parent693cf74ad265f9422d55ca610c800e5324222972 (diff)
downloadaur-c05ef71169f76e5e6f604671aa959acbe9d8005f.tar.gz
Fix building on i686
Without that, on i686 we have: /usr/bin/ld: ../libxtrxdsp.so.0.0.1: undefined reference to xtrxdsp_iq16_ic16i_avx' /usr/bin/ld: ../libxtrxdsp.so.0.0.1: undefined reference to xtrxdsp_iq16_ic16i_sse2' /usr/bin/ld: ../libxtrxdsp.so.0.0.1: undefined reference to `xtrxdsp_iq16_conv64_sse2' Signed-off-by: Denis 'GNUtoo' Carikli GNUtoo@cyberdimension.org PKGBUILD | 4 ++++ 1 file changed, 4 insertions(+)
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5591eb2209af..042f6e006df0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,8 +22,12 @@ build() {
cd "$srcdir/$_gitname"
mkdir -p build
cd build
+ if [ "$CARCH" = 'i686' ]; then
+ FORCE_ARCH="-DFORCE_ARCH=x86"
+ fi
cmake .. \
+ ${FORCE_ARCH} \
-DBUILD_SHARED_LIBS=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release