summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 06:55:12 -0600
committerBrian Bidulock2015-06-10 06:55:12 -0600
commitc35006d591d095a249c66e075a891897ea31043b (patch)
tree3744289268d19d9dfb28e67e85a49c3d999ad617
downloadaur-c35006d591d095a249c66e075a891897ea31043b.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c15035da49d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libxvnc
+ pkgdesc = X11 extention protocol library for the VNC extension
+ pkgver = 1.1
+ pkgrel = 2
+ url = https://github.com/bbidulock/libxvnc
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = vncproto
+ depends = libxext
+ source = https://github.com/bbidulock/libxvnc/releases/download/libxvnc-1.1/libXvnc-1.1.tar.bz2
+ md5sums = 949ed624250c66f035e5e93cab06e7fc
+
+pkgname = libxvnc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de08852d2d83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=libxvnc
+_pkgname=libXvnc
+pkgver=1.1
+pkgrel=2
+pkgdesc="X11 extention protocol library for the VNC extension"
+arch=('i686' 'x86_64')
+license=('GPL')
+url=("https://github.com/bbidulock/libxvnc")
+depends=('vncproto' 'libxext')
+source=("https://github.com/bbidulock/libxvnc/releases/download/libxvnc-1.1/libXvnc-1.1.tar.bz2")
+md5sums=('949ed624250c66f035e5e93cab06e7fc')
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="${pkgdir}" install
+}