summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean V Kelley2016-07-29 16:07:40 -0700
committerSean V Kelley2016-07-29 16:07:40 -0700
commita493ff7c8f96a00cb88e81fbb989ee3484d50da5 (patch)
tree57d96284965a2adc4928a78eb9d0399d2b542ca3
downloadaur-a493ff7c8f96a00cb88e81fbb989ee3484d50da5.tar.gz
Initial commit for libyami-utils
Signed-off-by: Sean V Kelley <seanvk@posteo.de>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86883a77ed28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libyami-utils
+ pkgdesc = Intel VA-API Media Applications and Scripts for libyami
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/01org/libyami-utils
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = libbsd
+ depends = libyami
+ depends = ffmpeg
+ options = !emptydirs
+ source = https://github.com/01org/libyami-utils/archive/0.1.0.tar.gz
+ sha256sums = 45de376a3f744f01c720ab0f0f33efde6dee75fcdfb8c1c1bdd434673ac1c565
+
+pkgname = libyami-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ac3b7ad142b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Sean V Kelley <seanvk@posteo.de>
+
+pkgname=libyami-utils
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Intel VA-API Media Applications and Scripts for libyami"
+arch=('i686' 'x86_64')
+url="https://github.com/01org/libyami-utils"
+license=('Apache')
+depends=('libbsd' 'libyami' 'ffmpeg')
+options=('!emptydirs')
+changelog=
+#source=($url/archive/$pkgver.tar.gz -> $pkgname-$pkgver.tar.gz)
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=('45de376a3f744f01c720ab0f0f33efde6dee75fcdfb8c1c1bdd434673ac1c565')
+
+build() {
+ export LD_RUN_PATH='$ORIGIN/lib/'
+ cd $pkgname-$pkgver
+ sh autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --with-package-name="Libyami Media Utils (Arch Linux)" \
+ --with-package-origin="http://www.archlinux.org/" \
+ --enable-avformat
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+ unset LD_RUN_PATH
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}