summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Franke2019-10-17 18:16:50 +0200
committerChristian Franke2019-10-17 18:16:50 +0200
commit549ca21e072737504d7a53e378be3ae5b043302d (patch)
tree569e9a7f69278519df0abcd9ea8109d96124975a
parent5217504f2828d4e90b029947c47d365ec29957bb (diff)
downloadaur-549ca21e072737504d7a53e378be3ae5b043302d.tar.gz
Append version to build dir
If the same build directory is used, CMake will complain that the cache is inconsistent. Avoid this by suffixing the build dir with the package version.
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 073ea63e93fe..80da5cb15015 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,11 +14,11 @@ source=("$_pkgsrc.tar.gz::https://github.com/CESNET/$pkgname/archive/v$_pkgver.t
sha256sums=('351f712433d50494aad153bfd4aa92ff50299058428620eabddb7a41d781e756')
prepare() {
- mkdir -p $srcdir/build
+ mkdir -p $srcdir/build-$_pkgver
}
build() {
- cd $srcdir/build
+ cd $srcdir/build-$_pkgver
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
@@ -28,7 +28,7 @@ build() {
}
package() {
- cd $srcdir/build
+ cd $srcdir/build-$_pkgver
make DESTDIR="$pkgdir" install
install -Dm644 $srcdir/$_pkgsrc/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}