summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2022-11-22 14:44:59 +0700
committerKonstantin Shalygin2022-11-22 14:44:59 +0700
commite9467e250e953e7f807bb26b6f639653df2b3f84 (patch)
tree1b19a597bb0fdb1c64374e3acfba8e0ebe5e286c
parent79e0432864fe2d77a0ec5690b524fffbdb7e9a70 (diff)
downloadaur-e9467e250e953e7f807bb26b6f639653df2b3f84.tar.gz
Bump to 2.1.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--b4cf6d1246f98d94f9c0ccf3d998478893488aca.patch54
3 files changed, 66 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 376941244231..f9e1bd7bc955 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libyang
pkgdesc = A YANG data modelling language parser and toolkit written (and providing API) in C
- pkgver = 2.0.231
+ pkgver = 2.1.4
pkgrel = 1
url = https://github.com/CESNET/libyang
arch = x86_64
@@ -17,7 +17,9 @@ pkgbase = libyang
depends = pcre2
conflicts = libyang-git
conflicts = libyang-devel-git
- source = https://github.com/CESNET/libyang/archive/v2.0.231.tar.gz
- sha256sums = 50c63a131bca2bee5867fd00f0e3357d9ed3d2a68e7ab7386af467e6d630ca31
+ source = https://github.com/CESNET/libyang/archive/v2.1.4.tar.gz
+ source = https://github.com/CESNET/libyang/commit/b4cf6d1246f98d94f9c0ccf3d998478893488aca.patch
+ sha256sums = f30ee1c3e13f0c5d25c4d2fb628e4b262b483d0a500464a7c12008ccc393a69e
+ sha256sums = 7d50d130c137f7c02c609419a0caf14e8f574faad5fcaaa1d1492f0058386e48
pkgname = libyang
diff --git a/PKGBUILD b/PKGBUILD
index 46abf6830a35..8488b533f89a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
pkgname='libyang'
-pkgver='2.0.231'
+pkgver='2.1.4'
pkgrel='1'
pkgdesc='A YANG data modelling language parser and toolkit written (and providing API) in C'
url="https://github.com/CESNET/${pkgname}"
@@ -12,11 +12,15 @@ depends=('pcre2')
makedepends=('cmake' 'swig' 'doxygen' 'graphviz')
checkdepends=('cmocka' 'shunit2' 'expect')
conflicts=('libyang-git' 'libyang-devel-git')
-source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('50c63a131bca2bee5867fd00f0e3357d9ed3d2a68e7ab7386af467e6d630ca31')
+source=("${url}/archive/v${pkgver}.tar.gz"
+"${url}/commit/b4cf6d1246f98d94f9c0ccf3d998478893488aca.patch")
+sha256sums=('f30ee1c3e13f0c5d25c4d2fb628e4b262b483d0a500464a7c12008ccc393a69e'
+ '7d50d130c137f7c02c609419a0caf14e8f574faad5fcaaa1d1492f0058386e48')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ # unit test hot fix
+ patch -p1 -i "${srcdir}/b4cf6d1246f98d94f9c0ccf3d998478893488aca.patch"
mkdir build
}
diff --git a/b4cf6d1246f98d94f9c0ccf3d998478893488aca.patch b/b4cf6d1246f98d94f9c0ccf3d998478893488aca.patch
new file mode 100644
index 000000000000..61320a936939
--- /dev/null
+++ b/b4cf6d1246f98d94f9c0ccf3d998478893488aca.patch
@@ -0,0 +1,54 @@
+From b4cf6d1246f98d94f9c0ccf3d998478893488aca Mon Sep 17 00:00:00 2001
+From: Michal Vasko <mvasko@cesnet.cz>
+Date: Wed, 9 Nov 2022 10:26:14 +0100
+Subject: [PATCH] tests BUGFIX ignore yanglint warnings
+
+Fixes #1936
+---
+ tools/lint/tests/expect/completion.exp | 3 ++-
+ tools/lint/tests/expect/feature.exp | 3 ++-
+ tools/lint/tests/expect/list.exp | 3 ++-
+ 3 files changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/tools/lint/tests/expect/completion.exp b/tools/lint/tests/expect/completion.exp
+index 971e105df..ed4f6bd45 100755
+--- a/tools/lint/tests/expect/completion.exp
++++ b/tools/lint/tests/expect/completion.exp
+@@ -10,7 +10,8 @@ if { [info exists ::env(CURRENT_SOURCE_DIR)] } {
+
+ spawn $yanglint
+
+-expect_output "> "
++# skip no dir and/or no history warnings
++expect_output "(YANGLINT.*)*> "
+
+ expect_command "clear -ii" 0 ""
+
+diff --git a/tools/lint/tests/expect/feature.exp b/tools/lint/tests/expect/feature.exp
+index d4073d370..37680b002 100755
+--- a/tools/lint/tests/expect/feature.exp
++++ b/tools/lint/tests/expect/feature.exp
+@@ -10,7 +10,8 @@ if { [info exists ::env(CURRENT_SOURCE_DIR)] } {
+
+ spawn $yanglint
+
+-expect_output "> "
++# skip no dir and/or no history warnings
++expect_output "(YANGLINT.*)*> "
+
+ expect_command "feature -a" 1 "yang:\r\n\t\\(none\\)\r\n\r\nietf-yang-schema-mount:\r\n\t\\(none\\)\r\n\r\n> "
+
+diff --git a/tools/lint/tests/expect/list.exp b/tools/lint/tests/expect/list.exp
+index 4264cfdae..ec3cdba1c 100755
+--- a/tools/lint/tests/expect/list.exp
++++ b/tools/lint/tests/expect/list.exp
+@@ -10,7 +10,8 @@ if { [info exists ::env(CURRENT_SOURCE_DIR)] } {
+
+ spawn $yanglint
+
+-expect_output "> "
++# skip no dir and/or no history warnings
++expect_output "(YANGLINT.*)*> "
+
+ expect_command "list" 1 "List of the loaded models:\r\n *i ietf-yang-metadata@2016-08-05\r\n *I yang@2022-06-16\r\n *i ietf-inet-types@2013-07-15\r\n *i ietf-yang-types@2013-07-15\r\n *I ietf-yang-schema-mount@2019-01-14\r\n *i ietf-yang-structure-ext@2020-06-17\r\n> "
+