summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov2015-09-21 13:59:16 +0200
committerLuka Perkov2015-09-21 14:07:52 +0200
commitef14c126a7feb98a50645317a9afa25e548f8407 (patch)
treec7e36e48ed8b19132a1680614d73d701909620d7
downloadaur-ef14c126a7feb98a50645317a9afa25e548f8407.tar.gz
initial commit
Signed-off-by: Luka Perkov <luka.perkov@sartura.hr>
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD36
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..686e8b0cedad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libyang-devel-git
+ pkgdesc = libyang is YANG data modelling language parser and toolkit written (and providing API) in C
+ pkgver = r351.136a519
+ pkgrel = 1
+ url = https://github.com/CESNET/libyang
+ arch = i686
+ arch = x86_64
+ license = BSD-3-Clause
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = make
+ makedepends = pkg-config
+ provides = libyang
+ conflicts = libyang
+ conflicts = libyang-git
+ replaces = libyang
+
+pkgname = libyang-devel-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cfc404d5bfe7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+libyang
+*.tar.gz
+*.tar.xz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bd056958505
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Luka Perkov <luka.perkov@sartura.hr>
+
+pkgname=libyang-devel-git
+_gitname=libyang
+pkgver=r667.67dcbf8
+pkgrel=1
+pkgdesc='libyang is YANG data modelling language parser and toolkit written (and providing API) in C'
+url='https://github.com/CESNET/libyang/'
+arch=('i686' 'x86_64' 'armv7h')
+license=('ISC BSD-3c')
+makedepends=('git' 'cmake' 'gcc' 'make' 'patch' 'pkg-config')
+conflicts=('libyang' 'libyang-git')
+provides=('libyang')
+source=('git+https://github.com/CESNET/libyang.git#branch=devel')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+
+ cmake CMakeLists.txt \
+ -DCMAKE_INSTALL_PREFIX=/usr
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+
+ make DESTDIR="$pkgdir" install
+}