summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkusakata2017-12-17 02:00:37 +0900
committerkusakata2017-12-17 02:00:37 +0900
commit048d713edb8ff0bf3d3544f11ec1bdc8d6f7f022 (patch)
treea20b36f81d46b234f07141af57e86ac94e819034
downloadaur-048d713edb8ff0bf3d3544f11ec1bdc8d6f7f022.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26a670aa28d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sat Dec 16 17:00:22 UTC 2017
+pkgbase = libzc
+ pkgdesc = Tool and library for cracking zip files
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = https://github.com/mferland/libzc
+ arch = x86_64
+ license = GPL3
+ depends = zlib
+ source = https://github.com/mferland/libzc/archive/v0.3.6.tar.gz
+ md5sums = 887a95c9e7458675c95a501e1c0acca9
+
+pkgname = libzc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a6d678a9ff7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: kusakata <shohei atmark kusakata period com>
+
+pkgname=libzc
+pkgver=0.3.6
+pkgrel=1
+pkgdesc="Tool and library for cracking zip files"
+url="https://github.com/mferland/libzc"
+license=('GPL3')
+arch=('x86_64')
+depends=('zlib')
+source=("https://github.com/mferland/libzc/archive/v${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums=('887a95c9e7458675c95a501e1c0acca9')