summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2024-05-19 11:39:20 +0200
committergit user2024-05-19 11:39:20 +0200
commit348a76fa23e26020491ba21f47402f7b72076846 (patch)
tree67d3bdecb918b8cca2c2a8e432997ae89329e7a2
parent6cbfadf8a1beb603cffd8012a836096fa7bc0d2a (diff)
downloadaur-348a76fa23e26020491ba21f47402f7b72076846.tar.gz
Fixed PKGBUILD.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 27 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e2c0710b001..579661fdcb7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
-# Generated by mksrcinfo v8
-# Thu Jan 17 13:45:23 UTC 2019
pkgbase = libzc
pkgdesc = Tool and library for cracking zip files
- pkgver = 0.4.1
+ pkgver = 0.4.3
pkgrel = 1
url = https://github.com/mferland/libzc
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
+ depends = gcc-libs
+ depends = glibc
depends = zlib
- source = https://github.com/mferland/libzc/archive/v0.4.1.tar.gz
- md5sums = 2f4dec4660959d4a0bda7838737ed8b5
+ source = libzc-0.4.3.tar.gz::https://github.com/mferland/libzc/archive/v0.4.3.tar.gz
+ sha256sums = 2c426bf5578b5ea5014ee0f75e52698ec648d426f8983b090342b566dcebf15b
pkgname = libzc
-
diff --git a/PKGBUILD b/PKGBUILD
index 18e66c7b9438..803e750b332b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,39 @@
# Maintainer: kusakata <shohei atmark kusakata period com>
pkgname=libzc
-pkgver=0.4.1
+pkgver=0.4.3
pkgrel=1
pkgdesc="Tool and library for cracking zip files"
url="https://github.com/mferland/libzc"
-license=('GPL3')
+license=('GPL-3.0-or-later')
arch=('x86_64')
-depends=('zlib')
-source=("https://github.com/mferland/libzc/archive/v${pkgver}.tar.gz")
+depends=(
+ 'gcc-libs'
+ 'glibc'
+ 'zlib'
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mferland/libzc/archive/v${pkgver}.tar.gz")
+sha256sums=('2c426bf5578b5ea5014ee0f75e52698ec648d426f8983b090342b566dcebf15b')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./autogen.sh
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --enable-year2038
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
+
make DESTDIR="$pkgdir" install
}
-
-md5sums=('2f4dec4660959d4a0bda7838737ed8b5')