summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2018-05-30 12:56:58 +0200
committerhashworks2018-05-30 12:56:58 +0200
commit14edb3c96859f75741d7cd5c21170eb73efa0c86 (patch)
tree43fa54fdc949834055ad90a0fe12a1b2667bcd65
parentfbd5e791e4657859551b70c0937fd6cfae464a6c (diff)
downloadaur-14edb3c96859f75741d7cd5c21170eb73efa0c86.tar.gz
Add gtest make dependency, add check()
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1372665ff8e7..178dbf84510d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = libzim
pkgdesc = Reference implementation of the ZIM specification by the openZIM project
pkgver = 3.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/openzim/libzim
arch = any
license = GPL2
makedepends = meson
+ makedepends = gtest
depends = zlib
depends = xz
depends = icu
diff --git a/PKGBUILD b/PKGBUILD
index 409c17d8fb88..23f5cc4c2255 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: hashworks <mail@hashworks.net>
pkgname=libzim
pkgver=3.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Reference implementation of the ZIM specification by the openZIM project"
license=('GPL2')
arch=('any')
replaces=('zimlib-git')
depends=('zlib' 'xz' 'icu')
-makedepends=('meson')
+makedepends=('meson' 'gtest')
url='https://github.com/openzim/libzim'
source=("https://github.com/openzim/libzim/archive/${pkgver}.tar.gz")
sha256sums=(043b21f39e856694492248f0bc1db037d2860360a2fe68bb2793140b216934d7)
@@ -18,6 +18,11 @@ build() {
ninja -C build
}
+check() {
+ cd "${pkgname}-${pkgver}/build"
+ ninja meson-test
+}
+
package() {
cd "${pkgname}-${pkgver}/build"
DESTDIR="${pkgdir}" ninja install