summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexej Magura2017-12-07 18:14:13 -0700
committerAlexej Magura2017-12-07 18:14:13 -0700
commitf16493d25420d8765907103751c7987ae6871bea (patch)
tree6f96bea2a7bef168100b44d94d40de1b73d49875
parent2c014fd5b4de7f791660ea8a4c02e2c3eec87246 (diff)
downloadaur-f16493d25420d8765907103751c7987ae6871bea.tar.gz
updates to doc inclusion code
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 596cb094a640..067787c003ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,9 @@ pkgdesc="a reliable pure C logging library"
arch=('i686' 'x86_64')
url="http://hardysimpson.github.com/zlog"
license=('LGPL')
-groups=()
depends=(glibc)
makedepends=(lyx texlive-bin hevea)
options=(!buildflags)
-install=
-changelog=
source=("https://github.com/HardySimpson/$_realname/archive/$pkgver.tar.gz"
"src-makefile.patch"
)
@@ -42,13 +39,9 @@ package()
install -d "$pkgdir/usr/share/$pkgname/doc"
rename mence mance doc/per*.txt # performence.txt is misspelled: this corrects it.
+ cp doc/UsersGuide-EN.html doc/Guide.html
+ cp doc/GettingStart-EN.txt doc/README
- for y in doc/{UsersGuide-EN.html,GettingStart-EN.txt,zlog.conf,performance.txt}; do
- [[ $y == 'doc/zlog.conf' || $y == 'doc/performance.txt' ]] || \
- cp "$y" "$(tr '[A-Z]' '[a-z]' <<<"$y" | sed 's/-en//')"
- install -t "$pkgdir/usr/share/$pkgname/doc" "$y"
- done
-
-
+ install -t "$pkgdir/usr/share/$pkgname/doc" doc/Guide.html doc/README doc/zlog.conf doc/performance.txt
}
# vim:set ts=2 sw=2 et: