summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakab Kristóf2015-10-25 10:09:36 +0100
committerJakab Kristóf2015-10-25 10:09:36 +0100
commit4fc319166b8a99b9b1020a0db450c04ec281e652 (patch)
tree48edcf871bc3de6d1f440697daffd8e4889bef23
downloadaur-4fc319166b8a99b9b1020a0db450c04ec281e652.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85bf88f4bb76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libzorpll
+ pkgdesc = Low level library functions for Zorp
+ pkgver = 6.0.6.0
+ pkgrel = 1
+ url = https://github.com/balabit/libzorpll
+ arch = x86_64
+ license = LGPL
+ depends = glib2
+ depends = libcap
+ depends = openssl
+ source = https://github.com/balabit/libzorpll/archive/v6.0.6.0.tar.gz
+ md5sums = 6a382bf03ed3b6a88651e184031918c0
+
+pkgname = libzorpll
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b78bfa0d3dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kristóf Jakab <jaksi@jaksi.io>
+pkgname=libzorpll
+pkgver=6.0.6.0
+pkgrel=1
+pkgdesc="Low level library functions for Zorp"
+arch=('x86_64')
+url="https://github.com/balabit/libzorpll"
+license=('LGPL')
+depends=('glib2' 'libcap' 'openssl')
+source=('https://github.com/balabit/libzorpll/archive/v6.0.6.0.tar.gz')
+md5sums=('6a382bf03ed3b6a88651e184031918c0')
+
+build() {
+ cd "$srcdir/libzorpll-6.0.6.0"
+ autoreconf -i
+ ./configure --prefix=/usr --libexecdir=/usr/lib/libzorpll
+ make
+}
+
+package() {
+ cd "$srcdir/libzorpll-6.0.6.0"
+ make DESTDIR="$pkgdir/" install
+ rm -r "$pkgdir/usr/var/"
+}