summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112017-02-10 06:45:32 +0100
committerjose17112017-02-10 06:45:32 +0100
commitead71c880871caf309db2bfbaf9ae4e687d67a03 (patch)
tree08a5ef27973c96d9f32adddbb7e4a9993ef7a919
downloadaur-ead71c880871caf309db2bfbaf9ae4e687d67a03.tar.gz
Initial commit to aur4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..891fe70f14e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Feb 10 05:44:29 UTC 2017
+pkgbase = libzrtpcpp
+ pkgdesc = A C++ implementation of Phil Zimmermann's ZRTP specification
+ pkgver = 4.6.3
+ pkgrel = 1
+ url = https://github.com/wernerd/ZRTPCPP
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = ccrtp
+ source = libzrtpcpp-4.6.3.tar.gz::https://github.com/wernerd/ZRTPCPP/archive/V4.6.3.tar.gz
+ md5sums = ccfaab35e2103033d9c414fee3d46a75
+
+pkgname = libzrtpcpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f09b563db821
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Jeff Mickey <jeff@archlinux.org>
+# Contributor: Michel Brabants <michel.brabants@euphonynet.be>
+
+pkgname=libzrtpcpp
+pkgver=4.6.3
+pkgrel=1
+pkgdesc="A C++ implementation of Phil Zimmermann's ZRTP specification"
+arch=('i686' 'x86_64')
+url='https://github.com/wernerd/ZRTPCPP'
+license=('GPL3')
+depends=('ccrtp')
+makedepends=('cmake')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/wernerd/ZRTPCPP/archive/V$pkgver.tar.gz")
+md5sums=('ccfaab35e2103033d9c414fee3d46a75')
+
+prepare() {
+ sed 's/lib64/lib/g' -i ZRTPCPP-${pkgver}/CMakeLists.txt
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake ../ZRTPCPP-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}