summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2020-09-23 17:59:04 +0300
committerYurii Kolesnykov2020-09-23 18:02:16 +0300
commit596ce02fcf2b84703aa2375192a7679c0d8b1e25 (patch)
tree17bb698f68243973115830e7c96cd988a24dd086
parent30952087aaaab05826a3aa0f65ff94dfc030ce0b (diff)
downloadaur-596ce02fcf2b84703aa2375192a7679c0d8b1e25.tar.gz
add yaml-cpp dep
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9e9bc9bb755..63fae9c34568 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = libzypp-git
pkgdesc = Library for package, patch, pattern and product management
- pkgver = 17.24.1.r9.g52f82f322
+ pkgver = 17.25.0.r7.gf247a52b7
pkgrel = 1
url = https://github.com/openSUSE/libzypp
- arch = i686
arch = x86_64
license = GPL
makedepends = asciidoc
@@ -19,9 +18,10 @@ pkgbase = libzypp-git
depends = gpgme
depends = libproxy
depends = libsigc++
- depends = libsolv
+ depends = libsolv-git
depends = libsystemd
depends = libxml2
+ depends = yaml-cpp
provides = libzypp
conflicts = libzypp
source = libzypp-git::git+https://github.com/openSUSE/libzypp.git
diff --git a/PKGBUILD b/PKGBUILD
index 715ef08a2497..eeb4af5db6d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,21 @@
_pkgname=libzypp
pkgname="${_pkgname}-git"
-pkgver=17.24.1.r9.g52f82f322
+pkgver=17.25.0.r7.gf247a52b7
pkgrel=1
pkgdesc='Library for package, patch, pattern and product management'
-arch=('i686' 'x86_64')
-url="https://github.com/openSUSE/libzypp"
+arch=('x86_64')
+url="https://github.com/openSUSE/${_pkgname}"
license=('GPL')
depends=(
'boost-libs'
'gpgme'
'libproxy'
'libsigc++'
- 'libsolv'
+ 'libsolv-git'
'libsystemd'
'libxml2'
+ 'yaml-cpp'
)
makedepends=(
'asciidoc'
@@ -34,7 +35,6 @@ conflicts=("${_pkgname}")
source=("${pkgname}::git+https://github.com/openSUSE/${_pkgname}.git")
sha256sums=('SKIP')
-
pkgver() {
cd "${pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -63,9 +63,9 @@ build() {
ninja -C build
}
-# check() {
-# ninja -C build test
-# }
+check() {
+ ninja -C build test
+}
package() {
DESTDIR="${pkgdir}" ninja -C build install