summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-09 18:01:42 +0300
committerDimitris Kiziridis2020-04-09 18:01:42 +0300
commit8d5490c679c7701d7c92c8a77652639bf6e25393 (patch)
tree21113c58e016b2f995c75197c4e515b4630cfc1c
downloadaur-8d5490c679c7701d7c92c8a77652639bf6e25393.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b50bbdcc6fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = licen-git
+ pkgdesc = Generate your license. Yet another lice, but implement with Jinja2 and docopt
+ pkgver = 0.2.1.r29.5969f6b
+ pkgrel = 1
+ url = https://github.com/lord63/licen
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-docopt
+ depends = python-jinja
+ source = git+https://github.com/lord63/licen
+ md5sums = SKIP
+
+pkgname = licen-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..454e889281f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=licen-git
+pkgver=0.2.1.r29.5969f6b
+pkgrel=1
+pkgdesc="Generate your license. Yet another lice, but implement with Jinja2 and docopt"
+arch=('any')
+url='https://github.com/lord63/licen'
+license=('MIT')
+depends=('python-docopt'
+ 'python-jinja')
+makedepends=('python-setuptools')
+source=("git+${url}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/licen
+ _version=$(awk -F ' ' 'NR==1{print substr($2,2,6)}' ${srcdir}/licen/ChangLog)
+ printf "$_version.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${srcdir}/licen
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/licen
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/licen/LICENSE"
+} \ No newline at end of file