summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzetty2023-08-05 02:50:37 +0200
committerzetty2023-08-05 02:52:18 +0200
commitf48253423fdd14e0a66d5f3cd8f6d83b0ad8539f (patch)
treeb0027e2e222e0c9c93fe77dbb1326a3778d81af4
downloadaur-f48253423fdd14e0a66d5f3cd8f6d83b0ad8539f.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7234d232592
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lichess-local-engine-bin
+ pkgdesc = Desktop app for Lichess external engine
+ pkgver = 0.0.5
+ pkgrel = 1
+ url = https://github.com/fitztrev/lichess-tauri
+ arch = x86_64
+ license = AGPL3
+ depends = gtk3
+ depends = webkit2gtk
+ depends = hicolor-icon-theme
+ provides = lichess-local-engine
+ conflicts = lichess-local-engine
+ source = https://github.com/fitztrev/lichess-tauri/releases/download/app-v0.0.5/lichess-local-engine_0.0.5_amd64.deb
+ sha256sums = cdb4b7824d861ce0837bfff0a9940b76434413bb8cbd9781c9bc80c537c3e7e9
+
+pkgname = lichess-local-engine-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0b9d911f60d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=lichess-local-engine-bin
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="Desktop app for Lichess external engine"
+arch=('x86_64')
+url="https://github.com/fitztrev/lichess-tauri"
+license=('AGPL3')
+depends=('gtk3' 'webkit2gtk' 'hicolor-icon-theme')
+provides=('lichess-local-engine')
+conflicts=('lichess-local-engine')
+source=("https://github.com/fitztrev/lichess-tauri/releases/download/app-v${pkgver}/lichess-local-engine_${pkgver}_amd64.deb")
+sha256sums=('cdb4b7824d861ce0837bfff0a9940b76434413bb8cbd9781c9bc80c537c3e7e9')
+
+package() {
+ bsdtar -xf "${srcdir}/data.tar.gz" -C "${pkgdir}"
+ mv "${pkgdir}/usr/share/icons/hicolor/256x256@2" "${pkgdir}/usr/share/icons/hicolor/256x256"
+}