aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Reeder2023-01-07 14:01:27 -0700
committerColin Reeder2023-01-07 14:01:27 -0700
commit5671ce5b93740b18a82d5cabc72726aad0ff3fd0 (patch)
treeb4b72db7a1c0832764384077f482af621b931369
parente401b345d03760925670f2ef782a974c6b14b686 (diff)
downloadaur-5671ce5b93740b18a82d5cabc72726aad0ff3fd0.tar.gz
Update to 8.0.0, disable sandbox to fix engine
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--index.js1
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c73f9f9fb001..bd6442d21760 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = lichobile-electron
pkgdesc = lichess.org mobile application, packaged with electron
- pkgver = 7.16.1
- pkgrel = 4
+ pkgver = 8.0.0
+ pkgrel = 2
url = https://lichess.org/mobile
arch = any
license = GPL-3.0-or-later
makedepends = npm
- source = https://github.com/veloce/lichobile/archive/refs/tags/v7.16.1.tar.gz
+ source = https://github.com/veloce/lichobile/archive/refs/tags/v8.0.0.tar.gz
source = appconfig.prod.json
source = run.sh
source = lichobile-electron.desktop
@@ -15,14 +15,14 @@ pkgbase = lichobile-electron
source = native-stockfish.patch
source = index.js
source = preload.js
- sha256sums = ddc8d51d3bf14636989874777ccf427bc27b38a9a581a1f652edd527e6af3f1c
+ sha256sums = 7ab9bcb1900ff1ff07197cc871e1c0f3e4b4d0ed964f5757d98dd58e73e822d3
sha256sums = a41fe45549f76234f1922a30289db674531a7fa4d11e355e57df2fbd2e5795aa
sha256sums = 759fd9dd1ee0423be68b0a0466bd059f71408fc8e1bff461c94b4378a23a2f49
sha256sums = d2773b69330634060130af9af2e157bb571653752983fb9df792378e1a29c512
sha256sums = 3d9e0bb9a5d16df02483263810cfa461263cd320f83baaf5ec69ad5c2b8c01fa
sha256sums = 3168ad338a32361887f6592ebaf503e0594f8d4e5facb5ad71e5b6f84650b396
sha256sums = d33f4ef5f0ad3fa0bee15c918199060f9e4148e96457285b1b6af7fdd1a741bd
- sha256sums = d9ad5a017455c237fa5227f0f97955b9c014a8281c16cd60d3f3bc524375bf12
+ sha256sums = 68af775157aba1028e10c8504e4e0ad06042f032913a0a6bc4a35fd29c3a6af7
sha256sums = 439a31acb844e7ca1afc670f8591c46f197c8ef65afea3df610704f19a8494c4
pkgname = lichobile-electron
diff --git a/PKGBUILD b/PKGBUILD
index e40cbe30a98f..5744e20cf622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@ shopt -s globstar
_pkgname=lichobile
pkgname="$_pkgname-electron"
-pkgver=7.16.1
-pkgrel=4
+pkgver=8.0.0
+pkgrel=2
pkgdesc="lichess.org mobile application, packaged with electron"
arch=(any)
url="https://lichess.org/mobile"
license=("GPL-3.0-or-later")
makedepends=(npm)
source=("https://github.com/veloce/lichobile/archive/refs/tags/v$pkgver.tar.gz" "appconfig.prod.json" "run.sh" "lichobile-electron.desktop" "lichesslogowhite.svg" "hide-scrollbar.patch" "native-stockfish.patch" "index.js" "preload.js")
-sha256sums=('ddc8d51d3bf14636989874777ccf427bc27b38a9a581a1f652edd527e6af3f1c'
+sha256sums=('7ab9bcb1900ff1ff07197cc871e1c0f3e4b4d0ed964f5757d98dd58e73e822d3'
'a41fe45549f76234f1922a30289db674531a7fa4d11e355e57df2fbd2e5795aa'
'759fd9dd1ee0423be68b0a0466bd059f71408fc8e1bff461c94b4378a23a2f49'
'd2773b69330634060130af9af2e157bb571653752983fb9df792378e1a29c512'
'3d9e0bb9a5d16df02483263810cfa461263cd320f83baaf5ec69ad5c2b8c01fa'
'3168ad338a32361887f6592ebaf503e0594f8d4e5facb5ad71e5b6f84650b396'
'd33f4ef5f0ad3fa0bee15c918199060f9e4148e96457285b1b6af7fdd1a741bd'
- 'd9ad5a017455c237fa5227f0f97955b9c014a8281c16cd60d3f3bc524375bf12'
+ '68af775157aba1028e10c8504e4e0ad06042f032913a0a6bc4a35fd29c3a6af7'
'439a31acb844e7ca1afc670f8591c46f197c8ef65afea3df610704f19a8494c4')
prepare() {
diff --git a/index.js b/index.js
index ba5fa395046c..0a445eda3952 100644
--- a/index.js
+++ b/index.js
@@ -7,6 +7,7 @@ app.whenReady().then(() => {
backgroundColor: "#161512",
webPreferences: {
preload: path.join(app.getAppPath(), "preload.js"),
+ sandbox: false,
},
});
mainWindow.loadFile("www/index.html");