summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkitsunyan2018-06-12 06:59:12 +0300
committerkitsunyan2018-06-12 06:59:12 +0300
commitd65ac6f119ce4849e99d4481f097e72b27647e61 (patch)
treefcd30f2a1286cfd462358a7eddeb0fae2ecef053
downloadaur-d65ac6f119ce4849e99d4481f097e72b27647e61.tar.gz
addpkg: lid-switch-dpms 1.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a29f0002aad9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lid-switch-dpms
+ pkgdesc = Blank and unblank the screen on lid switch
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/kitsunyan/lid-switch-dpms
+ arch = any
+ license = GPL3
+ depends = libdrm
+ depends = libxext
+ source = lid-switch-dpms-1.0.tar.gz::https://github.com/kitsunyan/lid-switch-dpms/archive/1.0.tar.gz
+ sha256sums = bba53dcfa12821285892d1a7ada757dfeaf4c35e199e9de2bc896e8c9c5eae83
+
+pkgname = lid-switch-dpms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a779cf04a486
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: kitsunyan <`echo a2l0c3VueWFuQGFpcm1haWwuY2MK | base64 -d`>
+
+pkgname=lid-switch-dpms
+pkgver=1.0
+pkgrel=1
+pkgdesc='Blank and unblank the screen on lid switch'
+arch=('any')
+url="https://github.com/kitsunyan/$pkgname"
+license=('GPL3')
+depends=('libdrm' 'libxext')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('bba53dcfa12821285892d1a7ada757dfeaf4c35e199e9de2bc896e8c9c5eae83')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}