summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Frenzel2017-10-06 10:46:18 +0200
committerSven Frenzel2017-10-06 10:46:18 +0200
commit2e8b1ebe1ffcd6c3cf5f9a68e41f13ec2f7b76de (patch)
treefd43897af3a17f5b18771d1b49e1977fd3cdbfe6
downloadaur-2e8b1ebe1ffcd6c3cf5f9a68e41f13ec2f7b76de.tar.gz
First release on aur
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD40
-rw-r--r--lidarr.install11
-rw-r--r--lidarr.service16
-rw-r--r--lidarr.sysusers1
5 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19d4af161058
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = lidarr
+ pkgdesc = Music downloader for usenet and torrents.
+ pkgver = 0.2.0.53
+ pkgrel = 1
+ url = https://github.com/lidarr/Lidarr
+ install = lidarr.install
+ arch = any
+ license = GPL3
+ depends = mono
+ depends = libmediainfo
+ depends = sqlite
+ optdepends = sabnzbd: usenet downloader
+ optdepends = nzbget: usenet downloader
+ optdepends = transmission-cli: torrent downloader (CLI and daemon)
+ optdepends = transmission-gtk: torrent downloader (GTK+)
+ optdepends = transmission-qt: torrent downloader (Qt)
+ optdepends = deluge: torrent downloader
+ optdepends = rtorrent: torrent downloader
+ optdepends = jackett: torrent indexer proxy
+ optdepends = libgdiplus: provides a gdi+ compatible api
+ source = https://ci.appveyor.com/api/buildjobs/tv5i8fioqgjntw6l/artifacts/_artifacts%2FLidarr.react.0.2.0.53.linux.tar.gz
+ source = lidarr.service
+ source = lidarr.sysusers
+ sha512sums = 7ad2dc125e21208db9d6089d328113a9259f273f95a1b36bc89d8bcab2bc2f5dcfe665147e90435a995723690a3ec570b42af5fc660ecfea80839bd8a33b35a7
+ sha512sums = 47bdb3bcefa39fd095aeae7b8ed19c80b43f9d3a90e2537088ee6ec0fdbe3472c7524e9adbe5a949dc800ff47d98f4edd8e1e5427a1a6cd730305d4be65f04cf
+ sha512sums = ffd466960527256d8de1d9887d90d4da87486eff062950c46cbc4fd4af1ef89e7d5c070ef1e649b23a95fbab15651e289fd5bdc6d34649e4a6ecdf2f6da06622
+
+pkgname = lidarr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a66dcda42ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Sven Frenzel <aur@frenzel.dk>
+pkgname="lidarr"
+pkgver="0.2.0.53"
+pkgrel=1
+pkgdesc="Music downloader for usenet and torrents."
+arch=(any)
+url="https://github.com/lidarr/Lidarr"
+license=('GPL3')
+depends=('mono' 'libmediainfo' 'sqlite')
+optdepends=('sabnzbd: usenet downloader'
+ 'nzbget: usenet downloader'
+ 'transmission-cli: torrent downloader (CLI and daemon)'
+ 'transmission-gtk: torrent downloader (GTK+)'
+ 'transmission-qt: torrent downloader (Qt)'
+ 'deluge: torrent downloader'
+ 'rtorrent: torrent downloader'
+ 'jackett: torrent indexer proxy'
+ 'libgdiplus: provides a gdi+ compatible api')
+install='lidarr.install'
+source=("https://ci.appveyor.com/api/buildjobs/tv5i8fioqgjntw6l/artifacts/_artifacts%2FLidarr.react.0.2.0.53.linux.tar.gz"
+ "lidarr.service"
+ "lidarr.sysusers")
+noextract=()
+
+sha512sums=('7ad2dc125e21208db9d6089d328113a9259f273f95a1b36bc89d8bcab2bc2f5dcfe665147e90435a995723690a3ec570b42af5fc660ecfea80839bd8a33b35a7'
+ '47bdb3bcefa39fd095aeae7b8ed19c80b43f9d3a90e2537088ee6ec0fdbe3472c7524e9adbe5a949dc800ff47d98f4edd8e1e5427a1a6cd730305d4be65f04cf'
+ 'ffd466960527256d8de1d9887d90d4da87486eff062950c46cbc4fd4af1ef89e7d5c070ef1e649b23a95fbab15651e289fd5bdc6d34649e4a6ecdf2f6da06622')
+
+package() {
+ cd "$srcdir"
+
+ install -d -m 755 "${pkgdir}/var/lib/lidarr"
+ install -d -m 755 "${pkgdir}/usr/lib/lidarr"
+ cp -dpr --no-preserve=ownership "${srcdir}/Lidarr/"* "${pkgdir}/usr/lib/lidarr"
+
+ find "${pkgdir}/usr/lib/lidarr" -type f -exec chmod 644 '{}' ';'
+
+ install -D -m 644 "${srcdir}/lidarr.service" "${pkgdir}/usr/lib/systemd/system/lidarr.service"
+ install -Dm644 "$srcdir/lidarr.sysusers" "$pkgdir/usr/lib/sysusers.d/lidarr.conf"
+}
diff --git a/lidarr.install b/lidarr.install
new file mode 100644
index 000000000000..38b03456019f
--- /dev/null
+++ b/lidarr.install
@@ -0,0 +1,11 @@
+post_install() {
+ systemd-sysusers lidarr.conf
+
+ mkdir -p /var/lib/lidarr
+ chown -R lidarr:lidarr /var/lib/lidarr /usr/lib/lidarr
+}
+
+post_upgrade() {
+ post_install $1
+}
+
diff --git a/lidarr.service b/lidarr.service
new file mode 100644
index 000000000000..6f0f639bf726
--- /dev/null
+++ b/lidarr.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Lidarr Service
+After=syslog.target network.target
+
+[Service]
+Environment=MONO_TLS_PROVIDER=legacy
+User=lidarr
+Group=lidarr
+ExecStart=/usr/bin/mono --debug /usr/lib/lidarr/Lidarr.exe -nobrowser -data=/var/lib/lidarr
+Type=simple
+TimeoutStopSec=20
+KillMode=process
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/lidarr.sysusers b/lidarr.sysusers
new file mode 100644
index 000000000000..707bf969f249
--- /dev/null
+++ b/lidarr.sysusers
@@ -0,0 +1 @@
+u lidarr - "Lidarr daemon" /var/lib/lidarr