summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2018-03-17 12:57:44 -0700
committerDonald Webster2018-03-17 12:57:44 -0700
commitcc87066d2b9b570fbc5e52c584c99d6ba1488788 (patch)
treef7c98739532dc824b6228d37f1db967805004d02
parent51ef417f96c21032ef70ae26243b58d0d19b5e1b (diff)
downloadaur-cc87066d2b9b570fbc5e52c584c99d6ba1488788.tar.gz
Switch to hard coded url.
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ba7432d779d..1c5ce6668ebf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Until there are actual releases, get the most recent nightly build using @binhex fancy curl + regex for ease of use.
# https://ci.appveyor.com/project/lidarr/lidarr/branch/develop/artifacts
-lidarr_url=$(curl -s "https://services.lidarr.audio/v1/update/nightly/changes?os=linux" | grep -P -o -m 1 '(?<=url":")[^"]+' | head -1 )
+# lidarr_url=$(curl -s "https://services.lidarr.audio/v1/update/nightly/changes?os=linux" | grep -P -o -m 1 '(?<=url":")[^"]+' | head -1 )
pkgname="lidarr"
pkgver="0.2.0.306"
+_urlhash="hp3q5iu2chre0ic3"
pkgrel=1
pkgdesc="Music downloader for usenet and torrents."
arch=(any)
@@ -22,7 +23,7 @@ optdepends=("sabnzbd: usenet downloader"
"jackett: torrent indexer proxy"
"libgdiplus: provides a gdi+ compatible api")
-source=("${lidarr_url}"
+source=("https://ci.appveyor.com/api/buildjobs/${_urlhash}/artifacts/Lidarr.develop.${pkgver}.linux.tar.gz"
"lidarr.service"
"lidarr.tmpfiles"
"lidarr.sysusers")