summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2021-04-18 10:44:32 -0700
committerDonald Webster2021-04-18 10:48:44 -0700
commit78764ea2952cb8427f2a036206c1d40d33b84434 (patch)
treef3c6f3cfbc0e6f6a454e21cc48855183cab553b9
parent89ec2fdf7f16a26011bf01b49aeb0d2d719844c6 (diff)
downloadaur-78764ea2952cb8427f2a036206c1d40d33b84434.tar.gz
Switch to netcore.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD84
-rw-r--r--lidarr.service8
-rw-r--r--package_info5
4 files changed, 76 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95738c1cdf05..c17163a19631 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = lidarr
pkgdesc = Music download automation for usenet and torrents.
pkgver = 0.8.1.2135
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lidarr/Lidarr
- arch = any
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
license = GPL3
- depends = mono
depends = sqlite
depends = chromaprint
optdepends = sabnzbd: usenet downloader
@@ -19,14 +20,22 @@ pkgbase = lidarr
optdepends = qbittorrent-nox: torrent downloader (no X)
optdepends = jackett: torrent indexer proxy
optdepends = libgdiplus: provides a gdi+ compatible api
- source = https://github.com/lidarr/Lidarr/releases/download/v0.8.1.2135/Lidarr.master.0.8.1.2135.linux.tar.gz
+ options = !strip
+ options = staticlibs
source = lidarr.service
source = lidarr.tmpfiles
source = lidarr.sysusers
- sha512sums = 299b4e5ec6ee7497e19fbe64e5c7b71bef48b902d1553f37fa9a1e453a7e079f389ddf7220a0c721791da1a9effe926c1374c9a28737bc1f603429d94ecf4a3d
- sha512sums = 61d40f22f0187a0273dd9d766961ca6d65f96a550bf7999ce89d221847aaa754cfbfdfed309c9afca813d097ac999d5661f531d6619422782209de0f43f2d2e8
+ source = package_info
+ sha512sums = f867a24ff5d817167d639778d2bd93e375ff66e60017818649c083ca135820e918934bd4ec7473fead40db699e990914d1d3e736f59591b56d5578c121007e95
sha512sums = e40ce79a3e1741e7e06312797e652a85d199bd6d719ef953ea8c3c030756ee44e202956ac9e13cff17fac38312c27398f457f79923a7d0f56bd563a69af6ab63
sha512sums = ffd466960527256d8de1d9887d90d4da87486eff062950c46cbc4fd4af1ef89e7d5c070ef1e649b23a95fbab15651e289fd5bdc6d34649e4a6ecdf2f6da06622
+ sha512sums = cabbd3d6387f4198097573da23032d80c1fec11835c180e55a28ee54c79c821d3c49c039762cc3ddc5126efc37d50d93cdd89a75ff809a3d533533a30353933e
+ source_x86_64 = lidarr-0.8.1.2135-linux-core-x64.tar.gz::https://services.lidarr.audio/v1/update/master/updatefile?version=0.8.1.2135&os=linux&runtime=netcore&arch=x64
+ sha512sums_x86_64 = c91d1771595ab99720f0c04a05710a3588daa50adb78887c4071420625fe7d60d0228d144983595af9c1a72a916b3398453f37724d6f84b9c9aaf5a4ae7e4e04
+ source_aarch64 = lidarr-0.8.1.2135-linux-core-arm64.tar.gz::https://services.lidarr.audio/v1/update/master/updatefile?version=0.8.1.2135&os=linux&runtime=netcore&arch=arm64
+ sha512sums_aarch64 = 9e237eb757d1468ab79c0bba118f28a5a0ebf23df31ead47b89977357f4fd248aae8a54f4ca548dcef2b9fae16bf3bc8f172ba6d86cf4fa879f52b79721ce0ce
+ source_armv7h = lidarr-0.8.1.2135-linux-core-arm.tar.gz::https://services.lidarr.audio/v1/update/master/updatefile?version=0.8.1.2135&os=linux&runtime=netcore&arch=arm
+ sha512sums_armv7h = 7498be08221dc6166ca795591e0d498ecedcecfa475339bc1c4ae445f3b98cecbb00ff4f5398d497f958fd9f12afe0804990b3063529a70d1d6cffa4a9001e7c
pkgname = lidarr
diff --git a/PKGBUILD b/PKGBUILD
index ce80d619a32b..2b4831de0c90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,66 @@
# Maintainer: Sven Frenzel <aur@frenzel.dk>
+# Maintainer: Donald Webster <fryfrog@gmail.com>
+# Helpful url: https://services.lidarr.audio/v1/update/master?version=0.0.0.0&os=linux&runtime=netcore&arch=x64
pkgname='lidarr'
pkgver=0.8.1.2135
-pkgrel=1
-pkgdesc='Music download automation for usenet and torrents.'
-arch=(any)
-url='https://github.com/lidarr/Lidarr'
-license=('GPL3')
-depends=('mono' 'sqlite' 'chromaprint')
-optdepends=('sabnzbd: usenet downloader'
- 'nzbget: usenet downloader'
- 'transmission-cli: torrent downloader (CLI and daemon)'
- 'transmission-gtk: torrent downloader (GTK+)'
- 'transmission-qt: torrent downloader (Qt)'
- 'deluge: torrent downloader'
- 'rtorrent: torrent downloader'
- 'qbittorrent: torrent downloader'
- 'qbittorrent-nox: torrent downloader (no X)'
- 'jackett: torrent indexer proxy'
- 'libgdiplus: provides a gdi+ compatible api')
-
-source=("https://github.com/lidarr/Lidarr/releases/download/v${pkgver}/Lidarr.master.${pkgver}.linux.tar.gz"
- 'lidarr.service'
- 'lidarr.tmpfiles'
- 'lidarr.sysusers')
-
-sha512sums=('299b4e5ec6ee7497e19fbe64e5c7b71bef48b902d1553f37fa9a1e453a7e079f389ddf7220a0c721791da1a9effe926c1374c9a28737bc1f603429d94ecf4a3d'
- '61d40f22f0187a0273dd9d766961ca6d65f96a550bf7999ce89d221847aaa754cfbfdfed309c9afca813d097ac999d5661f531d6619422782209de0f43f2d2e8'
+pkgrel=2
+pkgdesc="Music download automation for usenet and torrents."
+arch=('x86_64' 'aarch64' 'armv7h')
+url="https://github.com/lidarr/Lidarr"
+license=("GPL3")
+depends=('sqlite' 'chromaprint')
+options=('!strip' 'staticlibs')
+optdepends=(
+ 'sabnzbd: usenet downloader'
+ 'nzbget: usenet downloader'
+ 'transmission-cli: torrent downloader (CLI and daemon)'
+ 'transmission-gtk: torrent downloader (GTK+)'
+ 'transmission-qt: torrent downloader (Qt)'
+ 'deluge: torrent downloader'
+ 'rtorrent: torrent downloader'
+ 'qbittorrent: torrent downloader'
+ 'qbittorrent-nox: torrent downloader (no X)'
+ 'jackett: torrent indexer proxy'
+ 'libgdiplus: provides a gdi+ compatible api'
+)
+
+source_x86_64=("lidarr-${pkgver}-linux-core-x64.tar.gz::https://services.lidarr.audio/v1/update/master/updatefile?version=${pkgver}&os=linux&runtime=netcore&arch=x64")
+source_aarch64=("lidarr-${pkgver}-linux-core-arm64.tar.gz::https://services.lidarr.audio/v1/update/master/updatefile?version=${pkgver}&os=linux&runtime=netcore&arch=arm64")
+source_armv7h=("lidarr-${pkgver}-linux-core-arm.tar.gz::https://services.lidarr.audio/v1/update/master/updatefile?version=${pkgver}&os=linux&runtime=netcore&arch=arm")
+
+source=(
+ 'lidarr.service'
+ 'lidarr.tmpfiles'
+ 'lidarr.sysusers'
+ 'package_info'
+)
+
+sha512sums=('f867a24ff5d817167d639778d2bd93e375ff66e60017818649c083ca135820e918934bd4ec7473fead40db699e990914d1d3e736f59591b56d5578c121007e95'
'e40ce79a3e1741e7e06312797e652a85d199bd6d719ef953ea8c3c030756ee44e202956ac9e13cff17fac38312c27398f457f79923a7d0f56bd563a69af6ab63'
- 'ffd466960527256d8de1d9887d90d4da87486eff062950c46cbc4fd4af1ef89e7d5c070ef1e649b23a95fbab15651e289fd5bdc6d34649e4a6ecdf2f6da06622')
+ 'ffd466960527256d8de1d9887d90d4da87486eff062950c46cbc4fd4af1ef89e7d5c070ef1e649b23a95fbab15651e289fd5bdc6d34649e4a6ecdf2f6da06622'
+ 'cabbd3d6387f4198097573da23032d80c1fec11835c180e55a28ee54c79c821d3c49c039762cc3ddc5126efc37d50d93cdd89a75ff809a3d533533a30353933e')
+sha512sums_x86_64=('c91d1771595ab99720f0c04a05710a3588daa50adb78887c4071420625fe7d60d0228d144983595af9c1a72a916b3398453f37724d6f84b9c9aaf5a4ae7e4e04')
+sha512sums_aarch64=('9e237eb757d1468ab79c0bba118f28a5a0ebf23df31ead47b89977357f4fd248aae8a54f4ca548dcef2b9fae16bf3bc8f172ba6d86cf4fa879f52b79721ce0ce')
+sha512sums_armv7h=('7498be08221dc6166ca795591e0d498ecedcecfa475339bc1c4ae445f3b98cecbb00ff4f5398d497f958fd9f12afe0804990b3063529a70d1d6cffa4a9001e7c')
+
+
package() {
+ # Update environment isn't needed.
rm -rf "${srcdir}/Lidarr/Lidarr.Update"
- install -d -m 755 "${pkgdir}/usr/lib/lidarr"
- cp -dpr --no-preserve=ownership "${srcdir}/Lidarr/"* "${pkgdir}/usr/lib/lidarr"
- chmod -R a=,a+rX,u+w ${pkgdir}/usr/lib/lidarr/
+
+ # The fpcalc binary comes from chromaprint.
+ rm -rf "${srcdir}/Lidarr/fpcalc"
+
+ install -d -m 755 "${pkgdir}/usr/lib/lidarr/bin"
+ cp -dpr --no-preserve=ownership "${srcdir}/Lidarr/"* "${pkgdir}/usr/lib/lidarr/bin"
+ chmod -R a=,a+rX,u+w "${pkgdir}/usr/lib/lidarr/bin"
+ chmod +x "${pkgdir}/usr/lib/lidarr/bin/Lidarr"
+
+ # Disable built in updater.
+ install -D -m 644 "${srcdir}/package_info" "${pkgdir}/usr/lib/lidarr"
+ echo "PackageVersion=${pkgver}-${pkgrel}" >> "${pkgdir}/usr/lib/lidarr/package_info"
install -D -m 644 "${srcdir}/lidarr.service" "${pkgdir}/usr/lib/systemd/system/lidarr.service"
install -D -m 644 "${srcdir}/lidarr.sysusers" "${pkgdir}/usr/lib/sysusers.d/lidarr.conf"
diff --git a/lidarr.service b/lidarr.service
index b98e8d665106..002edf55eceb 100644
--- a/lidarr.service
+++ b/lidarr.service
@@ -5,14 +5,8 @@ After=syslog.target network.target
[Service]
User=lidarr
Group=lidarr
-ExecStart=/usr/bin/mono --debug /usr/lib/lidarr/Lidarr.exe -nobrowser -data=/var/lib/lidarr
+ExecStart=/usr/lib/lidarr/bin/Lidarr -nobrowser -data=/var/lib/lidarr
Type=simple
-TimeoutStopSec=20
-SyslogIdentifier=lidarr
-
-# Lets built in updater work well.
-Restart=on-failure
-KillMode=process
[Install]
WantedBy=multi-user.target
diff --git a/package_info b/package_info
new file mode 100644
index 000000000000..b61b5cd943bf
--- /dev/null
+++ b/package_info
@@ -0,0 +1,5 @@
+# PackageVersion is added by PKGBUILD
+PackageAuthor=[lidarr](https://aur.archlinux.org/packages/lidarr/)
+UpdateMethod=External
+UpdateMethodMessage=flag [lidarr](https://aur.archlinux.org/packages/lidarr/) [out-of-date](https://aur.archlinux.org/pkgbase/lidarr/flag/), use an [aur helper](https://wiki.archlinux.org/index.php/AUR_helpers) or the [manual method](https://wiki.archlinux.org/index.php/Arch_User_Repository#Installing_packages) to update.
+Branch=master