summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDobroslaw Kijowski2020-11-18 22:59:22 +0100
committerDobroslaw Kijowski2020-11-18 22:59:22 +0100
commit6ba3c362609c972ae789862689032038ef27da38 (patch)
tree3bb16e33bd46f8096f3635c195928c6b85b0c5c4
parent09ab9591ee66695481ee848258276d1d1c17b778 (diff)
downloadaur-6ba3c362609c972ae789862689032038ef27da38.tar.gz
lief: compile shared library instead of static one
* Grab some patches from git. * Thanks for the suggestions @yuyichao!
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d28ea054c4c..f69a7a8125c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lief
pkgdesc = Library to instrument executable formats
pkgver = 0.10.1
- pkgrel = 2
+ pkgrel = 3
url = https://lief.quarkslab.com/
arch = x86_64
license = APACHE
@@ -10,7 +10,11 @@ pkgbase = lief
makedepends = python-setuptools
depends = python
source = git+https://github.com/lief-project/LIEF#tag=0.10.1
- md5sums = SKIP
+ source = https://github.com/lief-project/LIEF/pull/365/commits/68f61547226cfb3b09d1628bf11f68443b7a8bcf.diff
+ source = https://github.com/lief-project/LIEF/pull/365/commits/f9e88a6665e80675c67310089d43045ebd3b64ef.diff
+ sha256sums = SKIP
+ sha256sums = 65caea9a2316a5d3b8ffff742643cabb4e1d182b9fa7a2e41bbe02d892b94086
+ sha256sums = b7dcb28ee259410424578ddc89a2dc7fd7f605a4d266d06fa9919915b1efdb37
pkgname = lief
diff --git a/PKGBUILD b/PKGBUILD
index 1d2e6c006d55..c9ab763b4a01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,33 @@
pkgname=lief
pkgver=0.10.1
-pkgrel=2
+pkgrel=3
pkgdesc='Library to instrument executable formats'
arch=(x86_64)
url='https://lief.quarkslab.com/'
license=(APACHE)
depends=(python)
makedepends=(git cmake python-setuptools)
-source=("git+https://github.com/lief-project/LIEF#tag=${pkgver}")
-md5sums=(SKIP)
+source=("git+https://github.com/lief-project/LIEF#tag=${pkgver}"
+ https://github.com/lief-project/LIEF/pull/365/commits/68f61547226cfb3b09d1628bf11f68443b7a8bcf.diff
+ https://github.com/lief-project/LIEF/pull/365/commits/f9e88a6665e80675c67310089d43045ebd3b64ef.diff)
+sha256sums=(SKIP
+ 65caea9a2316a5d3b8ffff742643cabb4e1d182b9fa7a2e41bbe02d892b94086
+ b7dcb28ee259410424578ddc89a2dc7fd7f605a4d266d06fa9919915b1efdb37)
+
+prepare()
+{
+ cd "${srcdir}/LIEF"
+
+ patch -p1 < ../68f61547226cfb3b09d1628bf11f68443b7a8bcf.diff
+ patch -p1 < ../f9e88a6665e80675c67310089d43045ebd3b64ef.diff
+}
build() {
cd "${srcdir}/LIEF"
mkdir build
- cmake . -B build -DCMAKE_BUILD_TYPE=Release
+ cmake . -B build -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=1
make -C build
python setup.py build --build-temp=build
}