summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaohan Chen2019-11-22 19:38:20 -0500
committerYaohan Chen2019-11-22 19:43:52 -0500
commitb7914dcc67fdd20d26087cfc084e73036afcffd8 (patch)
tree94913375da615192a3961871839492a89ed96d0d
downloadaur-b7914dcc67fdd20d26087cfc084e73036afcffd8.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
-rwxr-xr-xligaturizer.sh3
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fd28585bb2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ligaturizer-git
+ pkgdesc = FontForge script to add ligatures to any coding font
+ pkgver = 4.r3.gdaa4dc8
+ pkgrel = 1
+ url = https://github.com/ToxicFrog/Ligaturizer
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = fontforge
+ optdepends = otf-fira-code: default font to copy ligatures from
+ provides = ligaturizer
+ source = ligaturizer::git+https://github.com/ToxicFrog/Ligaturizer.git
+ source = ligaturizer.sh
+ md5sums = SKIP
+ md5sums = 8aaf3b09e5040c727d9aa2c1eab0b464
+
+pkgname = ligaturizer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73467fa004ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
+pkgname=ligaturizer-git
+appname="${pkgname%-git}"
+pkgver=4.r3.gdaa4dc8
+pkgrel=1
+pkgdesc='FontForge script to add ligatures to any coding font'
+arch=(any)
+url=https://github.com/ToxicFrog/Ligaturizer
+license=(GPL)
+groups=()
+depends=(fontforge)
+optdepends=('otf-fira-code: default font to copy ligatures from')
+makedepends=(git)
+provides=("$appname")
+replaces=()
+backup=()
+options=()
+install=
+source=("$appname"::git+https://github.com/ToxicFrog/Ligaturizer.git
+ ligaturizer.sh)
+noextract=()
+md5sums=('SKIP'
+ '8aaf3b09e5040c727d9aa2c1eab0b464')
+
+pkgver() {
+ cd "$srcdir/$appname"
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/$appname"
+ sed -ie 's#fonts/fira/distr/otf#/usr/share/fonts/OTF#' ligaturize.py
+}
+
+package() {
+ cd "$srcdir/$appname"
+ install -Dm644 ligaturize.py "$pkgdir/usr/share/$appname/ligaturize.py"
+ install -Dm644 ligatures.py "$pkgdir/usr/share/$appname/ligatures.py"
+ install -Dm755 ../ligaturizer.sh "$pkgdir/usr/bin/ligaturizer"
+}
diff --git a/ligaturizer.sh b/ligaturizer.sh
new file mode 100755
index 000000000000..8d50482ced68
--- /dev/null
+++ b/ligaturizer.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+fontforge -lang py -script /usr/share/ligaturizer/ligaturize.py --output-dir . "$@"