summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:10:39 +0200
committerMaxime Gauduin2015-06-08 11:10:39 +0200
commitd31bd7297b7cfb43998eae55dbf7ecac62d3ad27 (patch)
treead826ec7b5038fd278a04669826b239dd32b0bb4
downloadaur-d31bd7297b7cfb43998eae55dbf7ecac62d3ad27.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--MKPKG5
-rw-r--r--PKGBUILD44
-rw-r--r--light-locker.install13
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02553fc2cbb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = light-locker-git
+ pkgdesc = A simple session locker
+ pkgver = 1.4.0.r5.f45fdd4
+ pkgrel = 1
+ url = https://github.com/the-cavalry/light-locker
+ install = light-locker.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = gnome-common
+ makedepends = intltool
+ depends = dbus-glib
+ depends = gtk3
+ depends = libxss
+ depends = libxxf86misc
+ depends = lightdm
+ provides = light-locker
+ conflicts = light-locker
+ source = git+https://github.com/the-cavalry/light-locker.git
+ sha256sums = SKIP
+
+pkgname = light-locker-git
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..7a40393ceba9
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,5 @@
+pkgname=('light-locker-git')
+
+check_git $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f29236f3c19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=light-locker-git
+pkgver=1.4.0.r5.f45fdd4
+pkgrel=1
+pkgdesc='A simple session locker'
+arch=('i686' 'x86_64')
+url='https://github.com/the-cavalry/light-locker'
+license=('GPL2')
+depends=('dbus-glib' 'gtk3' 'libxss' 'libxxf86misc' 'lightdm')
+makedepends=('git' 'gnome-common' 'intltool')
+provides=('light-locker')
+conflicts=('light-locker')
+install='light-locker.install'
+source=('git+https://github.com/the-cavalry/light-locker.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd light-locker
+
+ printf "%s" "$(git describe --tags | sed 's/-/.r/; s/-g/./; s/^v//')"
+}
+
+build () {
+ cd light-locker
+
+ ./autogen.sh \
+ --prefix='/usr' \
+ --localstatedir='/var' \
+ --sysconfdir='/etc' \
+ --disable-schemas-compile \
+ --disable-static \
+ --with-{mit-ext,systemd,xf86gamma-ext,x} \
+ --without-{console-kit,upower}
+ make
+}
+
+package() {
+ cd light-locker
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/light-locker.install b/light-locker.install
new file mode 100644
index 000000000000..43fe00f8d2e2
--- /dev/null
+++ b/light-locker.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: