summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpryme-svg2021-01-04 21:23:33 -0800
committerpryme-svg2021-01-04 21:23:33 -0800
commit48cae99aebba87d21d34433008e917ef1618a5bb (patch)
treed60c4eedbeca0e09544f2a8a3a40ccca5444cebe
parente014d8ef66c5778fd664f74a61f14e26b6a9f76f (diff)
downloadaur-48cae99aebba87d21d34433008e917ef1618a5bb.tar.gz
fix symlinked icon, install license, provides
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18cccfd9a41d..4833b5621e59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,16 @@ pkgbase = lightcord-bin
url = https://github.com/Lightcord/Lightcord
arch = x86_64
license = MIT
+ provides = lightcord
+ conflicts = lightcord-git
source = lightcord-bin-dev.zip::https://lightcord.org/api/v1/gh/releases/Lightcord/Lightcord/dev/lightcord-linux-x64.zip
source = Lightcord.desktop
source = https://raw.githubusercontent.com/Lightcord/LightcordLogos/master/lightcord/lightcord.png
+ source = https://raw.githubusercontent.com/Lightcord/Lightcord/master/LICENSE
md5sums = SKIP
md5sums = 93edcd577375c0b3b045b7fbd9dcf09a
md5sums = f1ace6f149a3d778bfb789d10181d877
+ md5sums = 738e1aa6aff38e2ced608999d58ff5d7
pkgname = lightcord-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2bea972ff4ff..86d791832580 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,18 @@ arch=("x86_64")
url="https://github.com/Lightcord/Lightcord"
license=('MIT')
depends=()
+provides=('lightcord')
+conflicts=('lightcord-git')
makedepends=()
source=("$pkgname-$pkgver.zip::https://lightcord.org/api/v1/gh/releases/Lightcord/Lightcord/$pkgver/lightcord-linux-x64.zip"
"Lightcord.desktop"
- "https://raw.githubusercontent.com/Lightcord/LightcordLogos/master/lightcord/lightcord.png")
-md5sums=("SKIP"
- "93edcd577375c0b3b045b7fbd9dcf09a"
- "f1ace6f149a3d778bfb789d10181d877")
+ "https://raw.githubusercontent.com/Lightcord/LightcordLogos/master/lightcord/lightcord.png"
+ "https://raw.githubusercontent.com/Lightcord/Lightcord/master/LICENSE"
+)
+md5sums=('SKIP'
+ '93edcd577375c0b3b045b7fbd9dcf09a'
+ 'f1ace6f149a3d778bfb789d10181d877'
+ '738e1aa6aff38e2ced608999d58ff5d7')
package() {
# Create the folder structure
@@ -24,9 +29,12 @@ package() {
# Copy files over and set rights
cp -a "$srcdir"/. "$pkgdir"/opt/lightcord
chmod 755 "$pkgdir"/opt/lightcord/lightcord
+
+ # Copy license
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# Link icon and add Desktop
- ln -s /opt/lightcord/lightcord.png "$pkgdir"/usr/share/pixmaps/lightcord.png
+ install -Dm644 "$pkgdir"/opt/lightcord/lightcord.png "$pkgdir"/usr/share/pixmaps
install -Dm644 "$pkgdir"/opt/lightcord/Lightcord.desktop -t "$pkgdir"/usr/share/applications
# Create symlink in /usr/bin; stolen from other PKGBUILDs