summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkillermoehre2016-02-15 19:31:22 +0100
committerkillermoehre2016-02-15 19:31:22 +0100
commitbea4cbeae846d29ecd2b216770aae03b38cb8f3e (patch)
treeb58406ba58e3510f0060284212045cf0b886dd09
downloadaur-bea4cbeae846d29ecd2b216770aae03b38cb8f3e.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
-rwxr-xr-xgdmflexiserver2
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60f27298d455
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Feb 15 18:30:47 UTC 2016
+pkgbase = lightdm-flexiserver
+ pkgdesc = Shell script to relay gdmflexiserver calls, such as from the Xfce Action Buttons panel plugin's Switch User command, to lightdm
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://wiki.archlinux.org/index.php/LightDM#User_switching_under_Xfce_4
+ arch = any
+ license = GPL
+ depends = lightdm
+ optdepends = light-locker: for locking the session after switching
+ conflicts = gdm
+ conflicts = lxdmflexiserver
+ source = gdmflexiserver
+ md5sums = 05a1b0acd7435891a7a70cbe3b89dc9c
+
+pkgname = lightdm-flexiserver
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f50d23690f9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Silvio Knizek <killermoehre@gmx.net>
+# Contributor: René Herman <rene dot herman at gmail dot com>
+
+pkgname=lightdm-flexiserver
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Shell script to relay gdmflexiserver calls, such as from the Xfce Action Buttons panel plugin's Switch User command, to lightdm"
+depends=('lightdm')
+optdepends=('light-locker: for locking the session after switching')
+conflicts=('gdm' 'lxdmflexiserver')
+arch=('any')
+url="https://wiki.archlinux.org/index.php/LightDM#User_switching_under_Xfce_4"
+license=('GPL')
+source=(gdmflexiserver)
+md5sums=('05a1b0acd7435891a7a70cbe3b89dc9c')
+
+package() {
+ install -D "$srcdir/gdmflexiserver" "$pkgdir/usr/bin/gdmflexiserver"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gdmflexiserver b/gdmflexiserver
new file mode 100755
index 000000000000..f63886101662
--- /dev/null
+++ b/gdmflexiserver
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/dm-tool switch-to-greeter