summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Poulin2015-11-28 15:40:53 -0500
committerMaxime Poulin2015-11-28 15:43:08 -0500
commitbf8f23af735df9e6b41021e2ee4679faded9fbc6 (patch)
tree5a0be98c19db8207eacef8dbf06b6343948805ff
downloadaur-bf8f23af735df9e6b41021e2ee4679faded9fbc6.tar.gz
Initial commit
Implements the fix described in https://wiki.archlinux.org/index.php/LightDM#User_switching_under_Xfce4
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
-rwxr-xr-xgdmflexiserver-fake.sh2
3 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfdc7a86ab95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lightdm-gdmflexiserver
+ pkgdesc = Dummy script for applications expecting gdm instead of lightdm
+ pkgver = 1
+ pkgrel = 1
+ arch = any
+ license = GPL
+ depends = lightdm
+ conflicts = gdm
+ source = gdmflexiserver-fake.sh
+ md5sums = SKIP
+
+pkgname = lightdm-gdmflexiserver
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75bc30686d73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Maxime Poulin <maxpoulin64@gmail.com>
+pkgname=lightdm-gdmflexiserver
+pkgver=1
+pkgrel=1
+pkgdesc="Dummy script for applications expecting gdm instead of lightdm"
+arch=('any')
+license=('GPL')
+depends=('lightdm')
+conflicts=('gdm')
+source=("gdmflexiserver-fake.sh")
+md5sums=('SKIP')
+
+package() {
+ install -dm0755 "$pkgdir/usr/bin"
+ install -m0755 "$srcdir/gdmflexiserver-fake.sh" \
+ "$pkgdir/usr/bin/gdmflexiserver"
+}
diff --git a/gdmflexiserver-fake.sh b/gdmflexiserver-fake.sh
new file mode 100755
index 000000000000..f63886101662
--- /dev/null
+++ b/gdmflexiserver-fake.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/dm-tool switch-to-greeter