summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavan Rikhi2017-07-13 14:47:34 -0400
committerPavan Rikhi2017-07-13 14:47:34 -0400
commit3be4941ff8147e509fb451a25fb6da459788c307 (patch)
treedce7cd874854055678e735569da6a083cade18c5
parent4b5198de9b1d27c71440815678d4c8402e26ad7d (diff)
downloadaur-3be4941ff8147e509fb451a25fb6da459788c307.tar.gz
Add Post-Install Message on Required Configuration
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--lightdm-mini-greeter.install20
3 files changed, 31 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8d8f3fa9a9a..fe417ebf7f12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Wed Apr 19 14:32:49 UTC 2017
+# Thu Jul 13 18:47:10 UTC 2017
pkgbase = lightdm-mini-greeter
pkgdesc = A Minimal, Configurable, Single-User GTK3 LightDM Greeter
pkgver = 0.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/prikhi/lightdm-mini-greeter
+ install = lightdm-mini-greeter.install
arch = i686
arch = x86_64
license = GPL3
@@ -12,7 +13,9 @@ pkgbase = lightdm-mini-greeter
depends = gtk3
backup = etc/lightdm/lightdm-mini-greeter.conf
source = https://github.com/prikhi/lightdm-mini-greeter/archive/0.1.3.zip
+ source = lightdm-mini-greeter.install
sha256sums = fd27f5301dc49c1949580faea0a28e3def40926bb889d9aeba9a2b07fdf439a4
+ sha256sums = 63262e5c86cff52542e0f2028a0ef2566a5d9ac00fac368f459269202f659d7b
pkgname = lightdm-mini-greeter
diff --git a/PKGBUILD b/PKGBUILD
index beffc2a83a57..55b33d4d5363 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,18 @@
# Maintainer: Pavan Rikhi <pavan.rikhi@gmail.com>
pkgname=lightdm-mini-greeter
pkgver=0.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="A Minimal, Configurable, Single-User GTK3 LightDM Greeter"
arch=('i686' 'x86_64')
url="https://github.com/prikhi/lightdm-mini-greeter"
license=('GPL3')
depends=('lightdm' 'gtk3')
backup=('etc/lightdm/lightdm-mini-greeter.conf')
-source=("https://github.com/prikhi/lightdm-mini-greeter/archive/$pkgver.zip")
-sha256sums=('fd27f5301dc49c1949580faea0a28e3def40926bb889d9aeba9a2b07fdf439a4')
+source=("https://github.com/prikhi/lightdm-mini-greeter/archive/$pkgver.zip"
+ "lightdm-mini-greeter.install")
+sha256sums=('fd27f5301dc49c1949580faea0a28e3def40926bb889d9aeba9a2b07fdf439a4'
+ '63262e5c86cff52542e0f2028a0ef2566a5d9ac00fac368f459269202f659d7b')
+install="lightdm-mini-greeter.install"
build() {
cd "$pkgname-$pkgver"
diff --git a/lightdm-mini-greeter.install b/lightdm-mini-greeter.install
new file mode 100644
index 000000000000..abc2c1867f9a
--- /dev/null
+++ b/lightdm-mini-greeter.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo "==>"
+ echo "==> To enabled lightdm-mini-greeter, change the following config files:"
+ echo "==>"
+ echo "==> /etc/lightdm/lightdm.conf"
+ echo "==> greeter-session = lightdm-mini-greeter"
+ echo "==> user-session = gnome # Or anything from /usr/share/xsessions"
+ echo "==>"
+ echo "==> /etc/lightdm/lightdm-mini-greeter.conf"
+ echo "==> user = <your_username>"
+ echo "==>"
+ echo "==> Then logout & restart lightdm:"
+ echo "==>"
+ echo "==> sudo systemctl restart lightdm"
+ echo "==>"
+}
+
+post_upgrade() {
+ post_install
+}