summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLartza2015-07-07 14:39:06 +0300
committerLartza2015-07-07 14:39:06 +0300
commit3eccba858b2fcd1f24cb5993d2b250de56503a49 (patch)
tree154b83973ea4a6780d94a56ee5958761c407077e
downloadaur-3eccba858b2fcd1f24cb5993d2b250de56503a49.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rwxr-xr-xPKGBUILD42
-rwxr-xr-xlightdm-webkit-greeter.conf19
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f25c2ff3972
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = lightdm-webkit-greeter-bzr
+ pkgdesc = Webkit greeter for LightDM
+ pkgver = 13
+ pkgrel = 5
+ url = https://launchpad.net/lightdm-webkit-greeter
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ makedepends = bzr
+ makedepends = gnome-common
+ makedepends = intltool
+ depends = lightdm
+ depends = webkitgtk2
+ provides = lightdm-webkit-greeter
+ conflicts = lightdm-webkit-greeter
+ backup = etc/lightdm/lightdm-webkit-greeter.conf
+ source = lightdm-webkit-greeter::bzr+http://bazaar.launchpad.net/~lightdm-team/lightdm-webkit-greeter/trunk/
+ source = lightdm-webkit-greeter.conf
+ sha256sums = SKIP
+ sha256sums = 96c76474299ea286b39a9327b760393ca8f6bfb6065ae3eb118d22609bcf9980
+
+pkgname = lightdm-webkit-greeter-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a585b2d11396
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Alucryd <alucryd at gmail dot com>
+# Contributor: Christian Hesse <mail at eworm dot de>
+# Contributor: pmelo86 <patrick at patrickmelo dot eti dot br>
+
+pkgname=lightdm-webkit-greeter-bzr
+pkgver=r13
+pkgrel=1
+pkgdesc="Webkit greeter for LightDM"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/lightdm-webkit-greeter"
+license=('GPL3' 'LGPL3')
+depends=('lightdm' 'webkitgtk2')
+makedepends=('bzr' 'gnome-common' 'intltool')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+backup=("etc/lightdm/${pkgname%-*}.conf")
+source=("${pkgname%-*}::bzr+http://bazaar.launchpad.net/~lightdm-team/lightdm-webkit-greeter/trunk/"
+ "${pkgname%-*}.conf")
+sha256sums=('SKIP'
+ '96c76474299ea286b39a9327b760393ca8f6bfb6065ae3eb118d22609bcf9980')
+
+pkgver() {
+ cd "${srcdir}"/${pkgname%-*}
+ printf "r%s" "$(bzr revno)"
+}
+
+build() {
+ cd "${srcdir}"/${pkgname%-*}
+
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/lightdm
+ make
+}
+
+package() {
+ cd "${srcdir}"/${pkgname%-*}
+
+ make DESTDIR="${pkgdir}" install
+ install -dm 755 "${pkgdir}"/etc/lightdm
+ install -m 644 ../${pkgname%-*}.conf "${pkgdir}"/etc/lightdm/${pkgname%-*}.conf
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/lightdm-webkit-greeter.conf b/lightdm-webkit-greeter.conf
new file mode 100755
index 000000000000..fbfb4df66582
--- /dev/null
+++ b/lightdm-webkit-greeter.conf
@@ -0,0 +1,19 @@
+#
+# background = Background file to use, either an image path or a color (e.g. #772953)
+# theme-name = GTK+ theme to use
+# font-name = Font to use
+# webkit-theme = Webkit theme to use
+# xft-antialias = Whether to antialias Xft fonts (true or false)
+# xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
+# xft-hintstyle = What degree of hinting to use (hintnone, hintslight, hintmedium, or hintfull)
+# xft-rgba = Type of subpixel antialiasing (none, rgb, bgr, vrgb or vbgr)
+#
+[greeter]
+#background=
+#theme-name=
+webkit-theme=webkit
+#font-name=
+#xft-antialias=
+#xft-dpi=
+#xft-hintstyle=
+#xft-rgba=