summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Laker2019-09-08 20:39:46 -0400
committerKyle Laker2019-09-08 20:39:46 -0400
commit5fd6e53e1db5cb36542bff6e2e177f9e4f035f0a (patch)
treec30371b1af7ff75960610d6d00b194492023d68b
downloadaur-5fd6e53e1db5cb36542bff6e2e177f9e4f035f0a.tar.gz
Initial version
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD37
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..113cb15df37d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lightdm-webkit-theme-litarvan-git
+ pkgdesc = Modern and full-featured LightDM theme
+ pkgver = v3.0.0.pre3.r23.gc79eb52
+ pkgrel = 1
+ url = https://github.com/Litarvan/lightdm-webkit-theme-litarvan
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = npm
+ depends = lightdm-webkit2-greeter
+ provides = lightdm-webkit-theme-litarvan
+ conflicts = lightdm-webkit-theme-litarvan
+ source = lightdm-webkit-theme-litarvan-git::git://github.com/Litarvan/lightdm-webkit-theme-litarvan/
+ sha512sums = SKIP
+
+pkgname = lightdm-webkit-theme-litarvan-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c2e50835c9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Kyle Laker <kyle+aur at laker dot email>
+# Contributor: Filipe LaĆ­ns (FFY00) <lains@archlinux.org>
+_basepkg="lightdm-webkit-theme-litarvan"
+pkgname="${_basepkg}-git"
+#pkgname=lightdm-webkit-theme-litarvan
+pkgver=v3.0.0.pre3.r23.gc79eb52
+pkgrel=1
+pkgdesc='Modern and full-featured LightDM theme'
+arch=('any')
+_github="github.com/Litarvan/$_basepkg"
+url="https://$_github"
+license=('BSD')
+depends=('lightdm-webkit2-greeter')
+conflicts=("$_basepkg")
+provides=("$_basepkg")
+makedepends=('git' 'npm')
+source=("$pkgname::git://$_github/")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ ./build.sh
+}
+
+package() {
+ cd "$pkgname/dist"
+
+ install -dm 755 "$pkgdir"/usr/share/lightdm-webkit/themes/litarvan
+ cp -r --no-preserve=ownership * "$pkgdir"/usr/share/lightdm-webkit/themes/litarvan/
+
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}