summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerome Matilla2020-09-13 17:51:27 +0800
committerGerome Matilla2020-09-13 17:51:27 +0800
commit127d51945d7402cc3c31f8c9e5e49d4f1b7c3805 (patch)
treec049b9d0156ab77b89e04690fae045661721cff4
parentac47762ca4c99c451f7c3cf48682f51e2d72ddec (diff)
downloadaur-127d51945d7402cc3c31f8c9e5e49d4f1b7c3805.tar.gz
improve PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abb7fc5186b4..911aa99e2ee9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = lightdm-webkit2-theme-glorious
- pkgdesc = a sleek, modern and glorified lightdm webkit2 theme
+ pkgdesc = A sleek, modern and glorified LightDM webkit2 theme
pkgver = 2.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/manilarome/lightdm-webkit2-theme-glorious
arch = any
license = GPL3
- depends = lightdm
- depends = lightdm-webkit2-greeter>=2.2.5-2
- source = https://github.com/manilarome/the-glorious-lightdm-webkit2-theme/archive/v2.0.3.tar.gz
- md5sums = SKIP
+ depends = lightdm-webkit2-greeter
+ source = https://github.com/manilarome/lightdm-webkit2-theme-glorious/releases/download/v2.0.3/lightdm-webkit2-theme-glorious-2.0.3.tar.gz
+ sha512sums = a36d945120d664e793e9f3e3cdd84db84bb2b1824349c1a71aaba83a39a57050c4e1bfa0ecf2b24fc4602dabe8a3c36e118c3ca805c5daa5f9355ec500579a10
pkgname = lightdm-webkit2-theme-glorious
diff --git a/PKGBUILD b/PKGBUILD
index 50bd2bc5d244..bb96c3ce3e02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,18 @@
pkgname=lightdm-webkit2-theme-glorious
pkgver=2.0.3
-pkgrel=1
-pkgdesc="a sleek, modern and glorified lightdm webkit2 theme"
+pkgrel=2
+pkgdesc="A sleek, modern and glorified LightDM webkit2 theme"
arch=('any')
-url="https://github.com/manilarome/lightdm-webkit2-theme-glorious"
+url="https://github.com/manilarome/$pkgname"
license=('GPL3')
-depends=('lightdm' 'lightdm-webkit2-greeter>=2.2.5-2')
-install=
-changelog=
-source=("https://github.com/manilarome/the-glorious-lightdm-webkit2-theme/archive/v$pkgver.tar.gz")
-md5sums=('SKIP')
+depends=('lightdm-webkit2-greeter')
+source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('a36d945120d664e793e9f3e3cdd84db84bb2b1824349c1a71aaba83a39a57050c4e1bfa0ecf2b24fc4602dabe8a3c36e118c3ca805c5daa5f9355ec500579a10')
package() {
- cd "$pkgdir"
- mkdir -p usr/share/lightdm-webkit/themes/
- rm -rf usr/share/lightdm-webkit/themes/lightdm-webkit2-theme-glorious
- cd usr/share/lightdm-webkit/themes/
- cp --recursive "$srcdir/lightdm-webkit2-theme-glorious-$pkgver" "glorious"
+ install -dm 755 "$pkgdir"/usr/share/lightdm-webkit/themes/glorious
+ cp -r --no-preserve=ownership * "$pkgdir"/usr/share/lightdm-webkit/themes/glorious/
+
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}