summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Bryskin2024-04-02 19:31:12 +0000
committerNikolay Bryskin2024-04-02 19:37:16 +0000
commitb1166ec7bcf98d5776e78e6f89faf1cb75794107 (patch)
tree43599797dda7c9bcacc15f6827a1d5923b066bb7
parent48410374ed7ec352051e9ac8176d8cb9b05dae72 (diff)
downloadaur-b1166ec7bcf98d5776e78e6f89faf1cb75794107.tar.gz
Rename executable to lighthouse-ethereum
Remove provides,conflicts,replaces for "lighthouse".
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 3 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb3d81b29df7..24b77d9f1605 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lighthouse-ethereum
pkgdesc = Ethereum 2.0 client
pkgver = 5.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://lighthouse.sigmaprime.io/
arch = x86_64
arch = aarch64
@@ -11,9 +11,6 @@ pkgbase = lighthouse-ethereum
makedepends = clang
makedepends = protobuf
depends = openssl
- provides = lighthouse
- conflicts = lighthouse
- replaces = lighthouse
source = git+https://github.com/sigp/lighthouse.git#tag=v5.1.3
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bfaf522b2f4e..af28cacf10c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,13 @@
pkgname=lighthouse-ethereum
pkgver=5.1.3
_pkgname=lighthouse
-pkgrel=1
+pkgrel=2
pkgdesc='Ethereum 2.0 client'
arch=('x86_64' 'aarch64')
url='https://lighthouse.sigmaprime.io/'
license=('Apache License 2.0')
depends=('openssl')
makedepends=('cargo' 'cmake' 'clang' 'protobuf')
-provides=('lighthouse')
-conflicts=('lighthouse')
-replaces=('lighthouse')
source=("git+https://github.com/sigp/lighthouse.git#tag=v$pkgver")
sha256sums=('SKIP')
@@ -22,6 +19,6 @@ build() {
package() {
cd ${_pkgname}
- install -D -m755 "$srcdir/$_pkgname/target/release/lighthouse" "$pkgdir/usr/bin/lighthouse"
+ install -D -m755 "$srcdir/$_pkgname/target/release/lighthouse" "$pkgdir/usr/bin/lighthouse-ethereum"
install -D -m644 "$srcdir/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}