summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2022-03-15 18:02:33 +1100
committerJP-Ellis2022-03-15 18:02:33 +1100
commit1959ddbfe3f4875e453fc5676771c0f1780b8f86 (patch)
tree1bd6610f234456663309cd6232730f560a4ea5f9
parent24c365a9af1ea344bd25e5edc97214d30f75e75d (diff)
downloadaur-1959ddbfe3f4875e453fc5676771c0f1780b8f86.tar.gz
Add aarch64
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f3c63d74bf6..cb34fb0bb974 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,12 +4,15 @@ pkgbase = lighthouse-ethereum-bin
pkgrel = 1
url = https://lighthouse.sigmaprime.io/
arch = x86_64
+ arch = aarch64
license = Apache License 2.0
depends = openssl
provides = lighthouse
conflicts = lighthouse
replaces = lighthouse
- source = https://github.com/sigp/lighthouse/releases/download/v2.1.4/lighthouse-v2.1.4-x86_64-unknown-linux-gnu.tar.gz
- sha256sums = 9eb89a69790132f2fb13f605c7c220a3021a89ae165eeccd0d34041922064456
+ source_x86_64 = https://github.com/sigp/lighthouse/releases/download/v2.1.4/lighthouse-v2.1.4-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums_x86_64 = 9eb89a69790132f2fb13f605c7c220a3021a89ae165eeccd0d34041922064456
+ source_aarch64 = https://github.com/sigp/lighthouse/releases/download/v2.1.4/lighthouse-v2.1.4-aarch64-unknown-linux-gnu.tar.gz
+ sha256sums_aarch64 = 121e33edc34947073068deceacc4a0ea32ebd10d9b395bd48b08c797c9ad94a3
pkgname = lighthouse-ethereum-bin
diff --git a/PKGBUILD b/PKGBUILD
index b81630286829..26cc2454295a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,17 @@ _pkgname=lighthouse
pkgver=2.1.4
pkgrel=1
pkgdesc='Ethereum 2.0 client'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url='https://lighthouse.sigmaprime.io/'
license=('Apache License 2.0')
depends=('openssl')
provides=('lighthouse')
conflicts=('lighthouse')
replaces=('lighthouse')
-source=("https://github.com/sigp/lighthouse/releases/download/v${pkgver}/lighthouse-v${pkgver}-x86_64-unknown-linux-gnu.tar.gz")
-sha256sums=('9eb89a69790132f2fb13f605c7c220a3021a89ae165eeccd0d34041922064456')
+source_x86_64=("https://github.com/sigp/lighthouse/releases/download/v${pkgver}/lighthouse-v${pkgver}-x86_64-unknown-linux-gnu.tar.gz")
+source_aarch64=("https://github.com/sigp/lighthouse/releases/download/v${pkgver}/lighthouse-v${pkgver}-aarch64-unknown-linux-gnu.tar.gz")
+sha256sums_x86_64=('9eb89a69790132f2fb13f605c7c220a3021a89ae165eeccd0d34041922064456')
+sha256sums_aarch64=('121e33edc34947073068deceacc4a0ea32ebd10d9b395bd48b08c797c9ad94a3')
package() {
install -D -m755 "$srcdir/lighthouse" "$pkgdir/usr/bin/lighthouse"