summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2020-12-01 15:30:03 +1100
committerJP-Ellis2020-12-01 15:30:25 +1100
commit3700beac0f743d4e47987bac7224e368809daad3 (patch)
tree9ae0a3df50fef73c381bed977f2787f078e0f814
downloadaur-3700beac0f743d4e47987bac7224e368809daad3.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2e9dc6ef791
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lighthouse-ethereum-bin
+ pkgdesc = Ethereum 2.0 client
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://lighthouse.sigmaprime.io/
+ arch = x86_64
+ license = Apache License 2.0
+ depends = openssl
+ provides = lighthouse
+ conflicts = lighthouse
+ replaces = lighthouse
+ source = https://github.com/sigp/lighthouse/releases/download/v1.0.3/lighthouse-v1.0.3-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums = c1cfa0a2eced07f572e36ca00a40bdf4c55c5a8db5c602709898fdd2bc7caa0b
+
+pkgname = lighthouse-ethereum-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..335ec9573de5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d615fdabcd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=lighthouse-ethereum-bin
+pkgver=1.0.3
+_pkgname=lighthouse
+pkgrel=1
+pkgdesc='Ethereum 2.0 client'
+arch=('x86_64')
+url='https://lighthouse.sigmaprime.io/'
+license=('Apache License 2.0')
+depends=('openssl')
+provides=('lighthouse')
+conflicts=('lighthouse')
+replaces=('lighthouse')
+source=("https://github.com/sigp/lighthouse/releases/download/v${pkgver}/lighthouse-v${pkgver}-x86_64-unknown-linux-gnu.tar.gz")
+sha256sums=('c1cfa0a2eced07f572e36ca00a40bdf4c55c5a8db5c602709898fdd2bc7caa0b')
+
+package() {
+ install -D -m755 "$srcdir/lighthouse" "$pkgdir/usr/bin/lighthouse"
+}