summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseth2022-06-15 07:57:35 -0400
committerseth2022-06-15 08:00:57 -0400
commit004d3f10cc439da5c581c9147003ffe49f7c7007 (patch)
tree11521ede9ae2e43d10e43826658ac4728246ca6f
downloadaur-004d3f10cc439da5c581c9147003ffe49f7c7007.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD42
-rw-r--r--cmath.patch12
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca177d10a987
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lightmaputil-git
+ pkgdesc = A simple command line utility to tell you if your lightmaps are too high resolution
+ pkgver = r27.0ec24fd
+ pkgrel = 1
+ url = https://github.com/treacherousfiend/LightmapUtil
+ arch = x86_64
+ license = custom:none
+ makedepends = git
+ makedepends = cmake
+ provides = lightmaputil
+ conflicts = lightmaputil
+ source = lightmaputil::git+https://github.com/treacherousfiend/LightmapUtil
+ source = cmath.patch
+ sha512sums = SKIP
+ sha512sums = 2b306fa29c8d52f7b61b365e1009d9c335d30ad2584d89dcabbc3e0cdcf81ceebaa938f8184c3dbfc33ccce3f0381409adb13945d1526c0ab3748bd80a696615
+
+pkgname = lightmaputil-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2bd5e5095a60
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+*.log
+lightmaputil/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4daf438ddf18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: seth <g3tchoo at proton dot me>
+
+pkgname=lightmaputil-git
+pkgver=r27.0ec24fd
+pkgrel=1
+pkgdesc="A simple command line utility to tell you if your lightmaps are too high resolution"
+arch=('x86_64')
+url="https://github.com/treacherousfiend/LightmapUtil"
+license=('custom:none')
+makedepends=('git' 'cmake') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/treacherousfiend/LightmapUtil"
+ "cmath.patch")
+sha512sums=('SKIP'
+ '2b306fa29c8d52f7b61b365e1009d9c335d30ad2584d89dcabbc3e0cdcf81ceebaa938f8184c3dbfc33ccce3f0381409adb13945d1526c0ab3748bd80a696615')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 -i "$srcdir/cmath.patch"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ ..
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/build"
+ make install DESTDIR="${pkgdir}"
+}
diff --git a/cmath.patch b/cmath.patch
new file mode 100644
index 000000000000..a62e29e77f6c
--- /dev/null
+++ b/cmath.patch
@@ -0,0 +1,12 @@
+diff --git a/src/LightmapUtil.cpp b/src/LightmapUtil.cpp
+index ce742e8..62371a9 100644
+--- a/src/LightmapUtil.cpp
++++ b/src/LightmapUtil.cpp
+@@ -5,6 +5,7 @@
+ #include <vector>
+ #include <filesystem>
+ #include <cstring>
++#include <cmath>
+
+ #include "LightmapUtil.h"
+