summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2019-09-13 17:55:39 -0400
committerEli Schwartz2019-09-13 17:55:39 -0400
commit157687ba35401b2a44267ab4b172e9212340c247 (patch)
tree8891cd37a877f74fda15878b507c4284f1dc0849
downloadaur-157687ba35401b2a44267ab4b172e9212340c247.tar.gz
Dummy package to replace bad actors on the AUR.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rwxr-xr-xmodify.sh9
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..736f1afbc278
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,10 @@
+pkgbase = lightning-lang-patcher
+ pkgdesc = This package violates AUR guidelines
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://dev.null
+ arch = any
+ license = None
+
+pkgname = lightning-lang-patcher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05ef42637208
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
+
+# Dummy package to replace AUR content that has been taken down
+
+pkgname=lightning-lang-patcher
+pkgver=1.0
+pkgrel=1
+pkgdesc="This package violates AUR guidelines"
+arch=('any')
+url="http://dev.null"
+license=('None')
+
+build() {
+ /bin/false
+}
+
+package() {
+ /bin/false
+}
diff --git a/modify.sh b/modify.sh
new file mode 100755
index 000000000000..56dd3767c666
--- /dev/null
+++ b/modify.sh
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+sed -r -i 's@^(pkg(name|base) ?= ?)[^ ]+@\1'"$1@" PKGBUILD .SRCINFO
+
+git add PKGBUILD .SRCINFO modify.sh
+git commit --amend --reset-author --no-edit
+
+git fetch aur:$1 master:$1
+AUR_OVERWRITE=1 git push -f aur:$1 master