summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElrondo462019-09-14 07:54:37 +0200
committerElrondo462019-09-14 07:54:37 +0200
commitcd9a2f43f97e510f024765ff7f190832ab1cb3d2 (patch)
treec5b2cb0354b6c78036cc9df9bd5da08532c7131c
parent157687ba35401b2a44267ab4b172e9212340c247 (diff)
downloadaur-cd9a2f43f97e510f024765ff7f190832ab1cb3d2.tar.gz
From git now
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
-rwxr-xr-xmodify.sh9
3 files changed, 29 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 736f1afbc278..7d7c52e51d97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,15 @@
pkgbase = lightning-lang-patcher
- pkgdesc = This package violates AUR guidelines
- pkgver = 1.0
+ pkgdesc = Patch langs of Lightning thunderbird addon
+ pkgver = 1.4.5
pkgrel = 1
- url = http://dev.null
- arch = any
- license = None
+ url = https://www.tuxnvape.fr/
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = python-gobject
+ depends = thunderbird
+ source = https://github.com/Elrondo46/lightning-lang-patcher/archive/1.4.5.tar.gz
+ sha256sums = de519a7a580ff358ddaada89a7eea48df2df2bd30e4bff7754bf86e41b6cc7ef
pkgname = lightning-lang-patcher
diff --git a/PKGBUILD b/PKGBUILD
index 05ef42637208..338ad00d0b7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,25 @@
-# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
-
-# Dummy package to replace AUR content that has been taken down
+# Maintainer: Elrondo46 TuxnVape <elrond94@hotmail.com>
pkgname=lightning-lang-patcher
-pkgver=1.0
+pkgver=1.4.5
pkgrel=1
-pkgdesc="This package violates AUR guidelines"
-arch=('any')
-url="http://dev.null"
-license=('None')
+pkgdesc="Patch langs of Lightning thunderbird addon"
+arch=('x86_64')
+license=('GPL3')
+url="https://www.tuxnvape.fr/"
+depends=('python' 'python-gobject' 'thunderbird')
+source=("https://github.com/Elrondo46/lightning-lang-patcher/archive/${pkgver}.tar.gz")
-build() {
- /bin/false
-}
+sha256sums=('de519a7a580ff358ddaada89a7eea48df2df2bd30e4bff7754bf86e41b6cc7ef')
package() {
- /bin/false
-}
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/llp.desktop" "${pkgdir}/usr/share/applications/llp.desktop"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/lighttrans.py" "${pkgdir}/opt/lighttrans/lighttrans.py"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/llp.png" "${pkgdir}/usr/share/icons/llp.png"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/title.png" "${pkgdir}/opt/lighttrans/title.png"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/org.tnv.llp.policy" "${pkgdir}/usr/share/polkit-1/actions/org.tnv.llp.policy"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/transl.glade" "${pkgdir}/opt/lighttrans/transl.glade"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/config.json" "${pkgdir}/opt/lighttrans/config.json"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/llp.png" "${pkgdir}/opt/lighttrans/llp.png"
+}
+
diff --git a/modify.sh b/modify.sh
deleted file mode 100755
index 56dd3767c666..000000000000
--- a/modify.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-sed -r -i 's@^(pkg(name|base) ?= ?)[^ ]+@\1'"$1@" PKGBUILD .SRCINFO
-
-git add PKGBUILD .SRCINFO modify.sh
-git commit --amend --reset-author --no-edit
-
-git fetch aur:$1 master:$1
-AUR_OVERWRITE=1 git push -f aur:$1 master